txt2pdf (text to pdf): to convert txt, text, textual report, spool to pdf

txt2pdf (text to pdf)

To convert old txt, spool, text, textual report to nice pdf (form, invoice, report, sale sheet) on Windows, Solaris, Linux HP-UX, AIX, Mac OS X, tru64, openvms, sco, irix, bsd, ... Support for Japanese, Chinese (simplified and traditional), Korean, Czech, Greek, Polish, Hebrew, Thai languages.
Developed by SANFACE Software
Version 9.2 13 December 2006

Contents
  • What is txt2pdf?

  • Why do you need txt2pdf?

  • Download txt2pdf.
  • Purchasing, Licensing and Registration
    • Upgrade Policy
    • Volume Discounts
    • Reseller Discounts
    • No limit licenses
    • Annual maintenence fee. new
  • Getting executable txt2pdf.
  • Installing txt2pdf.
  • Configuration of txt2pdf.
  • Syntax.
  • Other features.
  • Multiuser features.
  • Documentation.
  • Update your txt2pdf version.
  • FAQ 2.1. update
  • Contributed programs and documentation.
  • Euro compliance.
  • What's new in this version?
  • Articles.
  • Read visual txt2pdf documentation ( The VB Windows GUI )
  • Explorer features.
  • log2pdf new
  • Read txt2pdf.cgi documentation.
  • txt2pdf PRO.
  • txt2pdf PRO + crypt support.
  • Links to txt2pdf and awards.
  • Books about PDF 1.6 and Acrobat 7.0. update

Important projects based on SANFACE Software Products.

Remember to evaluate also:

  • txt2pdf PRO
    To use in the background jpegs and to create compressed pdfs
  • txt2pdf PRO + crypt
    To create encrypted pdfs and to use in the background pdfs
What is txt2pdf?

txt2pdf is flexible and powerful tool to convert txt, text, textual report, spool into pdf (form, invoice, report, sale sheet). It can be used alone, or you can use it from other applications to convert your documents on the fly.

Why do you need txt2pdf?

Most of your documents are text files. Usually, your reports from legacy applications, COBOL applications, DBs, ERP applications and datawarehouse are textual. txt2pdf allows you to take those old text files and turn them into PDF's, which means you don't even need to pass the data through PostScript first.

You can run txt2pdf on any system that runs PERL (we have customers that use txt2pdf on OpenVMS, MPE, ...) or you can use a binary version on Windows, Solaris, HP-UX, AIX, Linux, Mac OS X (if you're interested in a binary for another operating system, such as FreeBSD, SCO Unix, Irix, Digital Unix (tru64), please let us know, and we'll send you one).

Here there are some of the things that you can achieve with txt2pdf:

  • Support for Japanese fonts (HeiseiMin-W3-90ms-RKSJ-H and HeiseiKakuGo-W5-90ms-RKSJ-H) normal, italic, bold, bolditalic and Japanese paper formats (JISB4 and JISB5).
    We have set that every ascii chars is just half of a Japanese char. This allows to convert this Japanese text into this pdf!
  • Support for Korean font (HYSMyeongJoStd KSCms-UHC-H) normal, italic, bold, bolditalic.
    We have set that every ascii chars is just half of a Korean char.
  • Support for simplified Chinese font (STSong GB-EUC-H) and traditional Chinese font (PMingLiU ETen-B5-H) normal, italic, bold, bolditalic.
    We have set that every ascii chars is just half of a traditionaland simplified Chinese char. This allows to convert this traditional Chinese text into this pdf!
  • Support for Czech, for Greek, Polish, Hebrew and Thai. (If you want different languages or different fonts for the supported languages contact us). new
  • txt2pdf supports STDIN and STDOUT.
  • You can mark coloured (using regular expressions) sentences in the produced PDF files.
  • You can mark bold, italic and bold italic sentences in the produced PDFfiles.
  • You can add page numbers on every page.
  • You can add text at the beginning and at the end of every file.
  • You can add a border to every page.
  • You can use background and foreground layers.
  • All predefined encoding (WinAnsiEncoding, MacRomanEncoding, MacExpertEncoding, PDFDocEncoding) supported by the PDF format and the Unix default are supported by txt2pdf.
  • It's possible to run through txt2pdf infinitely (every configured second, sleep feature) on a specific directory (and also its recursive directories) moving the produced PDF to a specific directory, and the original text to a specific directory.
  • mailto (mailcc, mailbcc) options: the possibility to send to the specified users (to, cc, bcc) the created PDF like attach. It's possible to specify the title, the body, the SMTP host, the from user (at the moment you can use these features only with the executable versions).
  • ftp support: the possibility to put the created PDF in the specified ftp site. It's possible to specify user, password and the final directory.
  • EPD 1.0 support. You can use EPD inside the background layer. See this example.
  • Internet specific phrases such as http://... ftp://... mailto:...file:... ldap:... news:... , setting linkuse, will automatically be made into clickable URL's.
  • You can create a link to a specific age within a PDF document just adding http://...pdfdocument#pdfmark
  • Every word like MIME:..., setting linkuse, will automatically become a link that launches the correct application to open that file.
  • A PE (Personal Edition) License is ONLY $39.
  • SANFACE Software is going to give you a free license for every good idea or good modify to txt2pdf.
Download txt2pdf

txt2pdf is available in several formats so you can download for your convenience. You may choose to download an executable file or you can just download the perl source code. Before you download our software, we ask you please to read the license and registration section to be aware of the licensing model which txt2pdf uses.

If you're interested in purchasing txt2pdf, please see the purchasing txt2pdf section.

We like perl, and that's the reason why we distribute txt2pdf primarily. This source code is our core business. We trust you. Please read the license and registration section.

The txt2pdf source code in .tar.gz format
The txt2pdf source code in .zip format 		get

Documentation

If you don't want to read this on-line always updated documentation and you prefer to download it on your computer you've now 3 ways:
  1. Windows Help
  2. html documentation
  3. You can extract from the perl code the perl documentation
Purchasing, Licensing and Registration

txt2pdf is shareware. That means that you're welcome to try it and use it as much as you want for 30 days. If after that time you like txt2pdf or would like to continue using it, we ask you please to purchase it or remove it from your system.

  • The txt2pdf source code is our company's core business. WE TRUST YOU.
  • You may modify and test txt2pdf, but you may only redistribute the txt2pdf tool in its original unchanged unregistered archive format (zip or tar.gz).
  • You are not allowed to use a modified version of txt2pdf for production purposes. If you wish to use txt2pdf on an ongoing basis, please see purchase out product.
  • You are not allowed to resell txt2pdf or any modified version of txt2pdf without SANFACE Software's authorization.
  • You are not allowed to re-use or include any txt2pdf source code in your own source code without SANFACE Software's authorization.
  • If you're a developer or a software house, and wish to use txt2pdf inside of your own applications, please email us directly at sanface@sanface.com

Only $39 for the Personal Edition
This means that you use the software for Personal purpose (home user, not inside a company). These are the fees for the Enterprise Edition:

  • $130 (US) for 1 CPU computer
  • $150 (US) for 2 or 3 CPU computers (or dual-core)
  • $175 (US) for 4 to 7 CPU computers
  • $205 (US) for 8 to 15 CPU computers
  • $240 (US) for 16 to more CPU computers
You can buy our software at RegSoft. Click the button below to purchase txt2pdf PE (Personal Edition):

Register NOW txt2pdf 9.x PE via a SECURE SERVER at www.RegSoft.COM Payment options include Credit Card, FAX Ordering, Postal Mail, Phone, Purchase Order.

Click the button below to purchase txt2pdf EE (Enterprise Edition):

Register NOW txt2pdf 9.x EE via a SECURE SERVER at www.RegSoft.COM Payment options include Credit Card, FAX Ordering, Postal Mail, Phone, Purchase Order.

Upgrade Policy

  • You can upgrade txt2pdf 6.x, 7.x, 8.x to the new version with the discount of the amount you previously paid + a fix fee for every license:

    • $20 for 8.x
    • $30 for 7.x
    • $40 for 6.x
    For example, if you paid $105 for your 6.x copy of txt2pdf and the new version costs $130, you will only pay $130 - $105 + $40 = $75.
    If you registered a previous release (1.x, 2.x, 3.x, 4.x, 5x) you have to buy a new license.
    Contact us via email at sanface@sanface.com for more information about how to upgrade your version.

Volume Discount

You can get the following bulk discounts:

PE (Personal Edition) |
4-10 licenses | $34 each
11 or more licenses | $24 each
EE (Enterprise Edition) |
4-10 licenses | $120 each (no CPU server difference)
11 or more licenses | $100 each (no CPU server difference)

Reseller Discount

Contact directly us! We're looking for resellers and partnerships.

No limit license

If you have one or more products with several installations and you want to use txt2pdf inside every tool of yours, here there is the license that you're looking for. It costs $1500 + 20% every year for PE (Personal Edition), $7500 + 20 % every year for EE (Enterprise Edition). Obviously you will receive free _every_ update.

Annual maintenence fee new

If you want the best support we can give you and the possibility to have in a year the upgrade of every minor and major release, now you can subscribe an annual maintenece fee. The price of annual maintenece fee is 20% of the actual txt2pdf amount. If you are interested ask us how to subscribe the annual maintenece fee.

Getting executable txt2pdf

txt2pdf has been specially compiled for those users who just can't or don't want to run Perl on their systems. It has all the functionalities of the original perl version, and is distributed only in binary form for your convenience.

We currently have 6 executable versions:

  • Windows (Self Extracting EXE file)

  • Windows (ZIP file)

  • Linux

  • Solaris

  • AIX

  • HP-UX (if you need an executable version for hp-ux 10.x Send us an email)

  • Mac OS X

If you're interested in a binary for another operating system, such as FreeBSD, SCO Unix, Irix, Digital Unix (tru64), please let us know, and we'll send you one. With enough requests, we'll also add one here permanently. Please note that the Windows version comes with an extra tool known as Visual txt2pdf. We convert using perl2exe.

Installing txt2pdf

  1. Create a directory for txt2pdf (eg. txt2pdf)

  2. Unpack the source file that you downloaded. For Windows, you can unzip using WinZip and for Linux and other Unix flavours, you can simply use GNU tar.

  3. Test if the executable perl file works by running the following:

    • ./txt2pdf.pl -h (Linux and other Unix flavours)
    • .\txt2pdf -h (Windows)
  4. Create your first PDF file on the fly by running the following:
    • txt2pdf(.pl) yourfile.txt
  5. The result is yourfile.pdf

Configuration of txt2pdf

  1. txt2pdf uses the file txt2pdf.cfg for its configuration file. This file must reside in the same directory as the txt2pdf.pl file, since it searches for this file at runtime. You can create your own txt2pdf.cfg file. Inside this file, you can change the values for the tmpdir, author, creator, keywords, subject, title, pdfversion, paper, landscape, font, lines, tab, pointSize, vertSpace, npage, border, beginfile, endfile, bgdesign, fgdesign, transition, pagemode, pagelayout, rotate, typencoding, withextension, colour, fontmark, sleep, pdfdir, txtdir, ViewerPreferences, fit, zoom, list, japanese, tradchinese, simplchinese, korean, pagemark, inputmod, outputmod, prepdf, annotationtext, underline, linkuse and noid variables. Only with the executable versions you can set also mailhost, mailfrom, notify, priority, mailsubject, mailbody, mail_body_file, sendmail, ftphost, ftpuser, ftppassword, ftpdirectory

  2. To change any of these values, you just need to edit txt2pdf.cfg. You can also create a new .cfg file and tell txt2pdf to read it at runtime, using the -configure yourfile.cfg option. In this section, we will discuss the most widely used variables, the one you are most likely to use with txt2pdf.

    With the tmpdir variable, you can specify the default directory to use for temporary files. You can use relative or absolute path names. The default directory is ./, but it's better if you specify a specific temporary directory that's in use for your system.

    eg.

            /tmp/ on Unix systems
    /temp/ | on Windows systems
    /desktop folder/temp | on MacOS systems
    /sys$scratch/ or SYS$SCRATCH | on OpenVMS
    #!ENV#TEMP#!/ENV# | to use TEMP environment variable

    The author, creator, keywords, subject and title variables allow you to set the relative fields in the PDF document that provides information about the document. If these values are not known, then they are just ommited. If the value of title is null, the file name is used as the default value of title.

    Author | The name of the person who created the document.
    Creator | If the document was created into a PDF from another form, this is the name of the application that created the original document.
    Keywords | Keywords that are associated with the document.
    Subject | The subject of the document.
    Title | The title of the document.

    The default value for pdfversion is 1.2. You can also use 1.3, 1.4, 1.5.
    The default value for paper is letter. You can also use A3 (or a3), A4 (or a4), A5 (or a5), tabloid, ledger, legal, statement, executive, jisb4, jisb5, widthxheight. By default, txt2pdf will write output in portrait, but this can be changed to landscape by setting this variable to 1 (the default is 0).
    With lines, you can set the maximum amount of lines per page (default (pageHeight-72)/vertSpace, pageHeight depends on the paper selected).
    With tab, you can set the amount of white space to be used for every tab (default is 8).
    The default font value is /F1 (normal Courier). You may also use these 14 PDF default fonts:

    • /F1 normal Courier
    • /F2 italic Courier
    • /F3 bold Courier
    • /F4 bolditalic Courier
    • /F5 normal Helvetica
    • /F6 italic Helvetica
    • /F7 bold Helvetica
    • /F8 bolditalic Helvetica
    • /F9 normal Times
    • /F10 italic Times
    • /F11 bold Times
    • /F12 bolditalic Times
    • /F13 Symbol
    • /F14 ZapfDingbats
    these 8 japanese fonts (remember to set japanese : 1):
    • /F20 HeiseiMin-W3-90ms-RKSJ-H
    • /F21 HeiseiMin-W3-90ms-RKSJ-H italic
    • /F22 HeiseiMin-W3-90ms-RKSJ-H bold
    • /F23 HeiseiMin-W3-90ms-RKSJ-H bolditalic
    • /F24 HeiseiKakuGo-W5-90ms-RKSJ-H
    • /F25 HeiseiKakuGo-W5-90ms-RKSJ-H italic
    • /F26 HeiseiKakuGo-W5-90ms-RKSJ-H bold
    • /F27 HeiseiKakuGo-W5-90ms-RKSJ-H bolditalic
    4 traditional chinese font (remember to set tradchinese : 1):
    • /F30 PMingLiU ETen-B5-H
    • /F31 PMingLiU ETen-B5-H italic
    • /F32 PMingLiU ETen-B5-H bold
    • /F33 PMingLiU ETen-B5-H bolditalic
    4 simplified chinese font (remember to set simplchinese : 1):
    • /F35 STSong GB-EUC-H
    • /F36 STSong GB-EUC-H italic
    • /F37 STSong GB-EUC-H bold
    • /F38 STSong GB-EUC-H bolditalic
    these 4 korean fonts (remember to set korean : 1):
    • /F40 HYSMyeongJoStd KSCms-UHC-H
    • /F41 HYSMyeongJoStd KSCms-UHC-H italic
    • /F42 HYSMyeongJoStd KSCms-UHC-H bold
    • /F43 HYSMyeongJoStd KSCms-UHC-H bolditalic

    With pointSize you can set the font point size (default 10).
    vertSpace is the distance between two lines (default 12).
    With the colour variable you can use a configuration file (e.g. colour.cfg) with a powerful syntax. (see point 3).
    With the fontmark variable you can use a configuration file (e.g. fontmark.cfg) with a powerful syntax. (see point 3).
    By setting npage to 1 (default is 0) you can add a page number to the end of every page.
    By setting border to 1 you can add a border to every page.
    With transition variable you can use these parameters:

    split!H!I! two lines sweep across revealing the new page image. The lines are Horizontal and move from the edge In
    split!H!O!     two lines sweep across revealing the new page image. The lines are Horizontal and move from the center Out
    split!V!I!     two lines sweep across revealing the new page image. The lines are Vertical and move from the edge In
    split!V!O!     two lines sweep across revealing the new page image. The lines are Vertical and move from the center Out
    blinds!H!     mulitple lines, evenly distributed across the screen, appear and synchronously sweep in the same direction to reveal the new page. The Vertcial lines move down.
    blinds!V!     mulitple lines, evenly distributed across the screen, appear and synchronously sweep in the same direction to reveal the new page. The Horizontalal lines move to the right.
    box!I!     a box from the edges Inward revealing the new page image.
    box!O!     a box from the center Out revealing the new page image.
    wipe!0!     a single line sweeps across the screen from one edge to the other, revealing the new page.
    wipe!90!     a single line sweeps across the screen from one edge to the other, revealing the new page.
    wipe!180!     a single line sweeps across the screen from one edge to the other, revealing the new page.
    wipe!270!     a single line sweeps across the screen from one edge to the other, revealing the new page.
    dissolve     the old image dissolves in a piecemeal fashion to reveal the new page.
    glitter!0!     similar to dissolve, except the effect sweeps across the image in a wide band moving from one side of the screen to the other.
    glitter!270!     similar to dissolve, except the effect sweeps across the image in a wide band moving from one side of the screen to the other.
    glitter!315!     similar to dissolve, except the effect sweeps across the image in a wide band moving from one side of the screen to the other.

    Note: PDF format supports only the described transition values
    With beginfile and endfile you can set a file where you can add the text you want to be added at the beginning or at the end of every file.
    With bgdesign and fgdesign you can set a background or foreground file. Inside you can use direct PDF syntax.
    Setting pagemode : FullScreen - the Acrobat Reader will open your document in full-screen mode. In full-screen mode, there is no menu bar, window controls, nor any other window present.
    The default pagelayout value is single page. You can use OneColumn (Display the pages in one column), TwoColumnLeft (Display the pages in two columns, with odd-numbered pages on the left), TwoColumnRight (Display the pages in two columns, with odd-numbered pages on the right), TwoPageLeft (this feature wil set PDF version 1.5) that display the pages two at a time, with odd-numbered pages on the left, TwoPageRight (this feature wil set PDF version 1.5) that display the pages two at a time, with odd-numbered pages on the right
    With the feature rotate you can rotate 90, 180, 270 degree all the pages of the document. This feature is very important if you need to create a landscape PDF file and want to send it to a fax. The solution is: to create a landscape PDF with rotate : 90
    With typeencoding you can select the correct encoding for your OS: WinAnsiEncoding, MacRomanEncoding, MacExpertEncoding, PDFDocEncoding are supported. The default is for Unix
    With withextension txt2pdf will create new PDFs appending .pdf to the original name (it won't change the original file extension with .pdf)
    sleep : seconds the program will re-run after the configured seconds
    pdfdir : directory to set the directory where to put the produced PDFs
    e.g. on Windows pdfdir : c:/mypdf/
    txtdir : directory to set the directory where to put the initial texts
    e.g. on Windows txtdir : c:/mytxt/
    NOTE : remember to put / at the end of the directory path
    ViewerPreferences : list where there is no list, one or more of these feature: /HideToolbar true /HideMenubar true /HideWindowUI true /FitWindow true /CenterWindow true
    /HideToolbar true to hide the viewer application’s tool bars when the document is active.
    /HideMenubar true to hide the viewer application’s menu bar when the document is active.
    /HideWindowUI true to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed.
    /FitWindow true to resize the document’s window to fit the size of the first displayed page.
    /CenterWindow true to position the document’s window in the center of the screen.
    fit : 1 to display the page designated, with its contents magnified just enough to fit the entire page within the window both horizontally and vertically.
    zoom : number to set the open of first page with the selected zoom. Default is zoom : 0 (that means don't use this feature) zoom : 1 means 100%. zoom : 1.5 means 150%
    list : file inside list file you can put a list of your input textual reports (one every line) using absolute or relative path
    japanese : 1 to add japanese font support (HeiseiMin-W3-90ms-RKSJ-H and HeiseiKakuGo-W5-90ms-RKSJ-H) tradchinese : 1 to add traditional chinese font support (PMingLiU ETen-B5-H) simplchinese : 1 to add simplified chinese font support (STSong GB-EUC-H) korean : 1 to add korean font support (HYSMyeongJoStd KSCms-UHC-H) inside the PDF (use this options only if you need to use the Japanese, Korean, simplified and traditional Chinese fonts).
    Setting pagemark : 1 you can open the PDF inside your browser at the page you prefer to use the URL http://your_site.your_ext/your_pdf_document#pagen where n is the number of the page e.g. http://www.sanface.com/pdf/test.pdf#page2
    With inputmod you can set a file where txt2pdf will execute the commands in every line on the input text. Using this feature you can create ad hoc filters. e.g. we have made a wrapper.pl filter to change the number of chars in every line of your textual reports.
    In our example the inputmod file is
    perl wrapper.pl #!input#
    With outputmod you can set a file where txt2pdf will execute the commands with the pdf output. Using this feature you can execute external command on the pdf outputs. e.g. you can move the pdfs in a web directory or send them via email or to a fax or etc.
    To put one or more lines before the beginning of the PDF now you can use inside txt2pdf.cfg prepdf.
    This feature can be very useful. On Xerox printers + DocuSP controller you can use Xerox Job ticket commands. The "options" must be placed at the beginning of the pdf file, before the %PDF. To print duplex you can use
    prepdf: %XRXbegin: 001.0300\n%XRXPDLformat: PDF\n%XRXrequirements: duplex\n%XRXend
    (\n means go to a new line)
    If you need more information about Xerox Job ticket or how to configure it don't hesitate to contact us.
    Pay attention: accordingly with PDF Specification 1.5 (specifically - Implementation Notes 13 and 14) PDF Header in form "%PDF-M.m" or "%!PS-Adobe-N.n PDF-M.m" should appear somewhere within the first 1024 bytes of the file. We suggest you to use this feature only to print the pdf! With annotationtext you can introduce the text you want to put in the annotation on the first page of your document.
    If inside a line of your textual report txt2pdf will find the special underline mark (the mark you have specified with underline option) the rest of the line will be write at the begin of the same line.
    e.g.
    This is a underlined line underline_mark_______________________________
    will become
    This is a underlined line
    In the previously txt2pdf release Internet specific phrases such as http://... ftp://... mailto:...file:... ldap:... news:... and mime: was automatically converted into clickable URL's.
    Now we have change policy for 2 reasons:
    the conversion is time consuming, Reader 7.x automatically converts www. and @ into links.
    If you want to use the old feature you have to set linkuse : 1
    We have added ID: (optional, but strongly recommended from PDF 1.1) a file identifier for the file. Although this entry is optional, its absence might prevent the file from functioning in some workflows that depend on files being uniquely identified. If yu don't want to use ID you can use noid : 1
    Only with the executable versions you can use set also:
    sendmail to set the local sendmail or similar command. The default is sendmail -t -oi -oem mailhost to set the local or remote smtp host (you can use also the ip address)
    notify the email address where you want to receive the notify of the read of your email.
    priority to set the email priority. The default 3 means X-Priority: 3 (Normal) and X-MSMail-Priority: Normal. You can use also 1 X-Priority: 1 (Highest) and X-MSMail-Priority: High or 5 X-Priority: 5 (Lowest) and X-MSMail-Priority: Low.
    mailfrom please change this default nobody@nobody.com with your email
    mailsubject the Subject of the email (Your report is the default)
    mailbody the body of the email (In attach your report is the default). You can make a multiline body using \n like end of line.
    mail_body_file an external file where it's possible to specify the body of the email.
    With ftphost, ftpuser, ftppassword, ftpdirectory you can set the ftp site, user, password and the directory where you want to put the final pdf.
  3. To convert Czech, Greek, Polish, Hebrew and Thai texts you can:
    • put the text into the correct directory (e.g. a Polish text into polish directory) inside Languages, enter inside the directory (cd) and run txt2pdf
    • copy all the configuration files (e.g. txt2pdf.cfg, language_name.txt, language_name.ttf) in a different directory and use them with your text
    If you want different languages or different fonts for the supported languages contact us.

  4. You can also configure colour and fontmark files. The following is the syntax for the colour.cfg file:
    string;number:number:number
    where number is > 0 < 1 (the PDF rgb syntax)
    String means every string you want to mark with the selected colour
    e.g. TOTAL FEDERAL GST ACTIVE;0.5:0:1
    You can change sentences with any colour you want.
    We use this line to make any internet link blue. Obviously you can change it with your preferred colour
    http://[^ \n]*;0:0:1
    ftp://[^ \n]*;0:0:1
    mailto:[^ \n]*;0:0:1
    mime:[^ \n]*;0:0:1
    https://[^ \n]*;0:0:1
    file:[^ \n]*;0:0:1
    ldap:[^ \n]*;0:0:1
    news:[^ \n]*;0:0:1
    You can use PERL regular expressions, and this is the reason why this is so powerful.
    e.g. ^Total federal.*active$;.7;.8;.2

    The following is the syntax for the fontmark.cfg file
    string;font
    where font is one of the 16 fonts.
    e.g. TOTAL GRAHAM PIES OLD;/F4
    That means: change the default font to the /F4 font in every string "TOTAL GRAHAM PIES OLD"
    You may also use PERL regular expressions here.

  5. Pay attention, from txt2pdf version 7.1 we suggest you to put design and text syntax not directly inside bgdesign but inside an EPD. The difference is that using bgdesign txt2pdf will put the line of text and design syntax in every page, with EPD txt2pdf will use import only one time the text and design syntax and links it. This means that with text documents with a lot of pages the final pdf will be smaller.
    Inside bgdesign and fgdesign files you can use directly the PDF syntax to draw and to write. These are a few examples:
    If you want to put a bold big diagonal DRAFT on every generated page, you can use the foreground file with:
    (REMEMBER to put the text instruction inside BT and ET)
    BT
    /F6 55 Tf
    .5 .5 -.5 .5 150 455 Tm
    (DRAFT) Tj
    ET

    /F6 means use italic Helvetica font
    55 is the point size.
    The meaning of the first line is: use the bold selected font with point size 55.
    The meaning of the second line is: start form point (150,455) and write diagonal.
    The meaning of the third line is: write DRAFT.
    Remember you can use inside bgdesign and fgdeisgn the 19 fonts. To use the Japanese fonts remember to set japanese : 1. To use the traditional chinese fonts remember to set tradchinese : 1. To use the simplified chinese fonts remember to set simplchinese : 1. To use the korean fonts remember to set korean : 1.
    If you want to draw a black background border line inside grey, you can use the background file with:
    .9 g
    0 G
    3 w
    25 25 545 792 re
    B

    The meaning of the first line is: inside the rectangle use grey (0 is black, 1 is white)
    The meaning of the second line is: the line is black
    The meaning of the third line is: the width of the line is 3
    The meaning of the fourth line is: the rectangle is (25,25) (545,792)
    The meaning of the fifth line is: draw.

    You can find the information about the PDF syntax you can use in the layers directly in The PDF Reference Manual Version 1.3 second edition PDF (696 pages, ~5 Mb) in the Chapter 4 and 5 (Page Descriptions). Inside bgdesign file you can use EPD vectorial objects
    This is the syntax:
    #!epd#epdf_file;z1;z2;z3;z4;x_position;y_position#!/epd#
    The first field is exact path where txt2pdf can find the EPD file (you can use also relative path)
    2nd, 3rd, 4th and 5th fields are very powerful and complex. You can use it to scale or even rotate the EPD.
    At the beginning, we suggest you use:
    z1=1, z2=0, z3=0, z4=1
    to scale correctly n EPD to divide or multiply z1 and z4 for the same integer
    You can find the information about the PDF transformation syntax in The PDF Reference Manual Version 1.3 second edition PDF (696 pages, ~5 Mb) in the Chapter 4.2.
    6th and 7th fields are the x and y position on the page (0,0 the bottom left corner)
    This is an example
    #!epd#../EPD/john.epd;1;0;0;1;50;400#!/epd#

  6. You can test your new files easily changing into the Tests directory and running the following command:
    ../txt2pdf(.pl) -c test.cfg test.txt
    test.pdf is the PDF output file
    On Unix OS, a simple STDIN and STOUT test is
    ls -l | txt2pdf - > ls.pdf
    On Windows OS
    dir | perl txt2pdf - > dir.pdf
    The - (minus char, like Unix style, means: read from standard input, write to standard output)

Syntax

Pay attention: you can use -mailto, -mailcc and -mailbcc only with the executable versions

txt2pdf [-options] files
where options include:
-help | print out this message
-configure file | default txt2pdf.cfg
-landscape |
-list file | a list of textual input files
-paper format | default letter, valid formats: A3 (or a3), A4 (or a4), A5 (or a5), widthxheight
-npage | add page number
-recursive directory | scan recursively the directory
-match files | match different files ex. *.pdf, a?.* (require -recursive option)
-border | border line
-pdfdir directory | the directory where you want to put the PDF's
-txtdir directory | the directory where you want to put the text
-mailto "name@domain.com" | to send the generated PDFs to the specify email addresses
-mailcc "name@domain.com" | to send the generated PDFs cc to the specify email addresses
-mailbcc "name@domain.com" | to send the generated PDFs bcc to the specify email addresses
-current | the program version
-verbose | verbose
-test | run a test without conversions
- | use STDIN and STDOUT
list:
with list you can use metacharacters and relative and absolute path names.
  • -configure filename: with this option you can configure an alternate configuration file (the default configuration file is txt2pdf.cfg, located in txt2pdf directory). This option is very useful if you use txt2pdf in an automatic task (e.g. cron).
    e.g.
    txt2pdf -c c.cfg *.c
    txt2pdf -c perl.cfg *.pl *.pm
  • -match files -recursive directory: with these option you can convert all the files in the directory and in every its subdirectories
    e.g
    txt2pdf -m "a*.txt" -r .
    will convert every file beginning with a and with txt extension to PDF inside the . directory and in every its subdirectories
  • Every file in the list is converted into a PDF file. If the file has an extension the extension is changed with .pdf extension, if the file doesn't have an extension the .pdf extension is added.
Other Features

  • CreationDate - The date the document was created is automatically set in the Info dictionary.

  • Automatic conversion of words like http://..., ftp://..., mailto:..., file:... etc to URL's.

  • Automatic conversion if mime:... links to launch the correct application to open a file (Windows)

  • POD Documentation inside.

Multiuser Features

txt2pdf is powerful enough for System Administrators to install globally and provide a default .cfg file for their users/organization. This can be easily done by:

  • setenv TXT2PDFCFG /path/to/default.cfg (This can be added to .bashrc, .cshrc etc for example)

  • define/system TXT2PDFCFG pathto:default.cfg (VMS in SYLOGIN.COM for example)

An user can still overwrite the default values by using another setenv or by defining in his own login files if he has a default .cfg file of his/her own. An user can still have a working directory with a txt2pdf.cfg and, if it exists, have it loaded. That allows him/her (without command line options) to setup fully functional working directories. Users may also use the -configure option to overwrite any defaults.

Euro Compliance

From The PDF Reference Manual Version 1.3 second edition "Note that in the WinAnsiEncoding, character code 128 is used for Euro." Remember you need a PDF 1.3 Reader (e.g. Acrobat Reader 4.xx) for this functionality. See the example you can find also in the Tests directory in every distribution.

What's new in this version?
  • In pagelayout feature we have added support for TwoPageLeft that display the pages two at a time, with odd-numbered pages on the left, TwoPageRight (this feature wil set PDF version 1.5) that display the pages two at a time, with odd-numbered pages on the right

Click here for an exhaustive history file.

Articles
  • COBOL Output to PDF (About Legacy Coding)
  • ebook making (Chinese or Japanese or Korean language) (http://www.waterwood.com.cn/)
  • Creating Adobe® Acrobat (PDF) Documents Directly from SAS® Software tm (SAS)
  • Betting on Linux at Andersen Printing - As change sweeps an industry - a $1,299 Linux machine saves one company two million a year
  • Making PDF: Portable Document Files (HTML Goodies)
  • Help Desk PDF on the Fly (WebTechniques)
  • A great freeware library makes adding PDF support to an app easy (MacTech)
  • txt2pdf (Italian language) (B2B.html.it)
  • Text2pdf od Sanface (Czech language)
  • txt2pdf on Amiga? Skript-Schätze and Das zweite Gesicht (Amiga Magazin) (German language)
txt2pdf is a trademark of SANFACE Software© 1998-2006.
Your technology glasses. We help you see your full potential.


Contributions
Contributed programs

Do you want to reformat your text before passing it to txt2pdf? e.g. do you want to justify it?
We suggest you use Text::Autoformat, an automatic plaintext reformatter written by Damian Conway. You can find it at search.CPAN.org.

The Windows executable version has now inside Visual txt2pdf: a VB graphical user interface. You can find the VB code (GPL licence) in the Visual_txt2pdf directory inside contributed part. It was developed by Cedric Foko

txt2pdf.cgi 3.0 and pdfindex 3.0 are now free code examples. Use and modify txt2pdf.cgi 3.0 to create your cgi based on txt2pdf!

Do you want to download your texts via Internet (http, ftp, ...) and passing it to txt2pdf? We suggest you use GNU wget, a freely available network utility to retrieve files from the World Wide Web using HTTP and FTP, the two most widely used Internet protocols. It works non-interactively, thus enabling work in the background, after having logged off. You can find it at GNU.

Text to PDF generation using a standard SCO lp command by Gavin Jackson new

!txt2pdf is a RiscOS frontend for txt2pdf [from Joern-Erik LEO Burkert]
Requires: JFShared-Library by Justin Fletcher, !Perl for RiscOS and txt2pdf
You can find it in the contributed/Acorn-Risc directory or directly at LEO's RisOS-page
See a screenshot of the program
We're looking for contributed frontends: Java, GTK, pTK.

Text-Flowchart is 'ASCII Flowchart maker' perl module created by Jim Thomason. You can find it at search.CPAN.org.
See this text Flowchart and its PDF convertion via txt2pdf (you can also find these examples in the Tests/flowchart directory).

Contributed documentation

  • Acorn-Risc note by Joern-Erik LEO Burkert
  • Amiga note by Joern-Erik LEO Burkert
  • Lotus Notes note by Charles Daniel
  • OpenVMS
  • Notes: Txt2pdf by Martin P.J. Zinser
  • Cyrillic note by Ilya Naumov
  • MPEiX: convert spoolfiles to PDF? note by Mark Bixby
  • Installing txt2pdf on 3000 by Bob McGregor

English documentation done by: Marc Silver

txt2pdf is a trademark of SANFACE Software© 2004.
Your technology glasses. We help you see your full potential.

mailto:sanface@sanface.com | WAP http://www.sanface.com/wap/
http://www.sanface.com | I-mode http://www.sanface.com/i/

In Association with amazon.com


txt2pdf FAQ

txt2pdf (normal, PRO, PRO + crypt) FAQ
Version 2.1 12 September 2005
  1. Which are the available executable versions?
  2. I've a different OS, how can I use txt2pdf?
  3. Where can I find perl documentation for my specific OS?
  4. Where can I find txt2pdf documentation for my specific OS?
  5. How can I change the default parameters?
  6. A step by step example of bgdesign new
  7. Pay attention: pdf is a binary file
  8. I use txt2pdf inside a script shell (or a cgi), it doesn't seem to work.
  9. How can make the text bold?
  10. Why can't I see accented words properly?
  11. Does txt2pdf support images?
  12. Does txt2pdf support Form Feed?
  13. How can I add a cover to my reports?
  14. How can I add a fixed page at the end of my reports?
  15. What are the fonts I can use?
  16. Can I create compressed PDFs?
  17. Can I create crypted PDFs?
  18. How can I protect the created pdfs from cut and paste?
  19. How can I design background forms?
  20. Why is it better to put text and desing syntax inside an EPD file than inside begdesing?
  21. Will Visual txt2pdf support languages different from English?
  22. When I tried to run Visual txt2pdf the following error message came up: "A required .DLL file, MSVBVM60.DLL, was not found."
  23. I've saved my word file as a text. When I convert it, I've only few lines on the PDF. What's the problem?
  24. How can I use STDIN (standard input) and STDOUT (standard output)?
  25. PDF Viewers/Readers new
  1. Which are the available executable versions?
    Windows, Linux, Solaris, AIX, HP-UX and Mac OS X. If you need we can send you also executables for BSD/OS, FreeBSD, IRIX, DEC OSF1 (we use perl2exe).
    To create the Windows self extracting distribution we use NSIS (Nullsoft SuperPiMP Install System)
  2. I've a different OS, how can I use txt2pdf?
    We use perl to develop our tools. So, you can use the perl version in every operating systems supported by PERL5, including MPEiX, OpenVMS, OS/390, OS400, EPOC, Mac classic and Mac OS X, SCO, ... (we suggest you to use perl 5.6)
    Here you can find the official HP perl executable distribution for OpenVMS.
    You can find the txt2pdf perl version on line. If you need the perl version of txt2pdf PRO or txt2pdf PRO + crypt, write us.
    Remember the perl code is our core business. We trust you.
  3. Where can I find perl documentation for my specific OS?
    • Perl on VMS, VMS-specific documentation for Perl and OpenVMS SW-list: Perl
    • perl hp freeware for mpe/ix or Perl/iX for HP e3000 MPE
    • Building and installing Perl for OS/390
    • MacPerl
    • Perl fo Psion
    • Perl 5.6 for Windows CE
  4. Where can I find txt2pdf documentation for my specific OS?
    • MPEiX: convert spoolfiles to PDF? by Mark Bixby and Installing txt2pdf on 3000 by Bob McGregor
    • txt2pdf on OpenVMS
    • txt2pdf on Acorn-Risc by Joern-Erik LEO Burkert
    • txt2pdf on Amiga by Joern-Erik LEO Burkert
  5. How can I change the default parameters?
    You can edit directly txt2pdf.cfg (or you can create your own your_txt2pdf.cfg and run txt2pdf -conf your_txt2pdf.cfg) or you can use the GUI Visual_txt2pdf on Windows
  6. A step by step example of bgdesign
    Remember: (0,0) in pdf is the left bottom angle and the unit is point.
    Letter widht is 612 and height 792 (A4 595 and 842)
    see the bgdesign.txt in Tests directory
    to design a line from (x1,y1) to (x2,y2)
    x1 y1 m
    x2 y2 l
    to design a rectangle with left bottom angle in (x1,y1) and width x2 and height y2
    x1 y1 x2 y2 re
    B means design
    Write text inside BT ... ET
    BT Begin Text, ET End Text
    To set the font Tf, e.g. /F9 9 Tf sets font F9 and font size 9 (see the list of supported fonts in txt2pdf documentation. If you need you can use every true type font but it's not simple to set)
    An example to set the left bottom angle where to start to write left to right 1 0 0 1 245 762 Tm
    To write Tj e.g. (BILLING PERIOD) Tj
    I suggest you to install ghostview to know the exact position (in points) of the pointer on the pdf page.
  7. Pay attention: pdf is a binary file.
    Pay attention: pdf is a binary file.
    If you have to move it with ftp remember to set binary.
    If you have to put it in a mail attach you can use the feature inside txt2pdf PRO or you have to set the mime type application/pdf using base 64.
  8. I use txt2pdf inside a script shell (or a cgi), it doesn't seem to work.
    txt2pdf can work by command line but it doesn't seem to work inside a script shell (or a cgi).
    Usually these are the 2 possible problems:
    • remember to use only absolute path (also inside confguration files)
      e.g. /path/txt2pdf -conf /path/txt2pdf.cfg /path/*.txt
    • verify that the user that runs the script or the cgi has the permission to write files in the txt2pdf temporary directory (the default is the same directory of the txt2pdf executable) and in the selected directory
  9. How can make the text bold?
    It's easy: inside txt2pdf.cfg you can set font : /F3 to set bold Courier.
  10. Why can't I see accented words properly?
    If your textual reports are made on unix, you've no problems.
    If your textual reports are made on Windows, you've to set typeencoding : WinAnsiEncoding.
    If your textual reports are made on Mac, you can use typeencoding : MacRomanEncoding or MacExpertEncoding.
  11. Does txt2pdf support images?
    Only txt2pdf PRO family can support jpegs inside layers (at the moment only RGB jpges).
    See the 2 nice PDFs made by txt2pdf PRO at http://www.sanface.com/pdf/Purchase_Order.pdf http://www.sanface.com/pdf/invoice.pdf A lot of words can't explain the power of txt2pdf PRO :)
  12. Does txt2pdf support Form Feed?
    Only txt2pdf PRO family can support the standard Unix Form Feed (Control L, hex C0).
  13. How can I add a cover to my reports?
    Using txt2pdf PRO family, if your textual reports start with Form Feed (it will create a blank first page), you can use the beginfile : your_beginfile.cfg to create your cover.
  14. How can I add a fixed page at the end of my reports?
    Using txt2pdf PRO family, if your textual reports end with Form Feed (this will create a blank last page), you can use the endfile : your_endfile.cfg to create your end page.
  15. What are the fonts I can use?
    You can use these 14 PDF default fonts:
    • /F1 normal Courier
    • /F2 italic Courier
    • /F3 bold Courier
    • /F4 bolditalic Courier
    • /F5 normal Helvetica
    • /F6 italic Helvetica
    • /F7 bold Helvetica
    • /F8 bolditalic Helvetica
    • /F9 normal Times
    • /F10 italic Times
    • /F11 bold Times
    • /F12 bolditalic Times
    • /F13 Symbol
    • /F14 ZapfDingbats
    these 8 japanese fonts (remember to set japanese : 1):
    • /F20 HeiseiMin-W3-90ms-RKSJ-H
    • /F21 HeiseiMin-W3-90ms-RKSJ-H italic
    • /F22 HeiseiMin-W3-90ms-RKSJ-H bold
    • /F23 HeiseiMin-W3-90ms-RKSJ-H bolditalic
    • /F24 HeiseiKakuGo-W5-90ms-RKSJ-H
    • /F25 HeiseiKakuGo-W5-90ms-RKSJ-H italic
    • /F26 HeiseiKakuGo-W5-90ms-RKSJ-H bold
    • /F27 HeiseiKakuGo-W5-90ms-RKSJ-H bolditalic
    4 traditional chinese font (remember to set tradchinese : 1):
    • /F30 PMingLiU ETen-B5-H
    • /F30 PMingLiU ETen-B5-H italic
    • /F30 PMingLiU ETen-B5-H bold
    • /F30 PMingLiU ETen-B5-H bolditalic
    4 simplified chinese font (remember to set simplchinese : 1):
    • /F35 STSong GB-EUC-H
    • /F35 STSong GB-EUC-H italic
    • /F35 STSong GB-EUC-H bold
    • /F35 STSong GB-EUC-H bolditalic
    these 4 korean fonts (remember to set korean : 1):
    • /F40 HYSMyeongJoStd KSCms-UHC-H
    • /F41 HYSMyeongJoStd KSCms-UHC-H italic
    • /F41 HYSMyeongJoStd KSCms-UHC-H bold
    • /F41 HYSMyeongJoStd KSCms-UHC-H bolditalic
    If you want to use a special True Type font you have to use txt2pdf PRO or txt2pdf PRO + crypt.
  16. Can I create compressed PDFs?
    Inside txt2pdf PRO and PRO + crypt distribution, using the Windows executable version or directly the perl code (installing zlib library and zlib perl module) you can create compressed PDFs.
  17. Can I create crypted PDFs?
    Only the version txt2pdf PRO + crypt can create crypted PDFs (40 and 128 bits) to set the impossibility to print, cut and paste, modify the PDF document (with or without a password).
  18. How can I protect the created pdfs from cut and paste?
    You've 2 ways:
    you can use txt2pdf PRO + crypt to create encrypted PDFs not allowing to the user to cut and paste them
    you can use a simple trick with txt2pdf PRO: make a link on the page with the rectangle dimension equal to the page dimension e.g. to your web. In this way you can't allow to the final use to cut and paste your pdf and you've created a pdf with in every page a banner to your web!
  19. How can I design background forms?
    With your preferred design tool + autotrace!
    Read this note.
    With your preferred design tool + pstoepd or using pstoepd on line service
  20. Why is it better to put text and design syntax inside an EPD file than inside begdesign?
    Pay attention, from txt2pdf version 7.1 we suggest you to put design and text syntax not directly inside bgdesign but inside an EPD. The difference is that using bgdesign txt2pdf will put the line of text and design syntax in every page, with EPD txt2pdf will use import only one time the text and design syntax and links it. This means that with text documents with a lot of pages the final pdf will be smaller.
  21. Will Visual txt2pdf support languages different from English?
    Probably it won't. We suggest you to use the wonderful LingoWare software
  22. When I tried to run Visual txt2pdf the following error message came up: "A required .DLL file, MSVBVM60.DLL, was not found."
    The Microsoft Visual Basic Virtual Machine x.x (MSVBVMxx.dll) is the core component of the Visual Basic Runtime, and is usually provided with the windows operative system. The version 6.0 was released with Windows 98 2nd Edition. Here you can find the Visual Basic runtime
  23. I've saved my word file as a text. When I convert it, I've only few lines on the PDF. What's the problem?
    Use TEXT ONLY WITH LINE BREAKS Word feature
  24. How can I use STDIN (standard input) and STDOUT (standard output)?
    "-" (minus) with txt2pdf means read from STDIN and print on STDOUT.
    Here an example with UNIX: cat your_file.txt | txt2pdf - > your_pdf.pdf
    Here an example with DOS: type your_file.txt | txt2pdf - > your_pdf.pdf
  25. PDF Viewers/Readers
    PDF is a widely used format and for this reason, there are many products that allow you to view PDF files. The following links will lead you to the more common known PDF viewers, where you can download PDF viewers for almost every operating system:

    • Adobe Acrobat Reader - This free viewer supports many languages and many different operating systems, among them: Windows (3.1, 95, 98, ME, NT, 2000, XP), Mac, OS/2 Warp, Linux, Solaris, IRIX, AIX, HP-UX, Digital UNIX, Palm OS, Pocket PC, Symbian OS

    • XPDF is a free PDF viewer for X-Windows on Unix, VMS and OS/2. It also supports Acorn, BeOS and Amiga (AmiPDF is the standard PDF reader in AmigaOS 4).

    • GhostScript: GSview - GSview is a graphical interface for Ghostscript. GSview is available for Win32/Win32s, OS/2 and Linux, MacGSView is a Mac graphical interface for Ghostscript.

    • PDF (free) and PDF+ (Shareware) - PDF viewer for all current Psion PDA's and compatibles e.g. Nokia 9210 and 9290 Communicator, SonyEricsson P800, Series 60 Smartphone.

    • Ansyr Primer PDF viewer - A viewer for Palm OS, Windows CE and Pocket PC.

txt2pdf is a trademark of SANFACE Software© 2005.
Your technology glasses. We help you see your full potential.

mailto:sanface@sanface.com | WAP http://www.sanface.com/wap/
http://www.sanface.com | I-mode http://www.sanface.com/i/

In Association with amazon.com


Visual txt2pdf

A SANFACE Software Tool.
Developed by Cedric Foko
Version 3.3.1 15th March 2004

Contents
  • What is Visual txt2pdf?
  • Why do you need Visual txt2pdf?
  • How can I customize Visual txt2pdf?
  • How can I use Visual txt2pdf?
  • Scheduler
  • Can the use of visual txt2pdf substitute the use of txt2pdf or txt2pdf PRO?
  • What's new in this version
  • Possible problems
  • Books about PDF

In Association with amazon.com

What is visual txt2pdf?

Visual txt2pdf is a Windows graphical user interface to txt2pdf and txt2pdf PRO. It is included in the Windows .zip files. It has been developed using Visual Basic.

Why do you need visual txt2pdf?

The purpose of Visual txt2pdf is to allow you to configure txt2pdf.cfg and execute txt2pdf (or txt2pdf PRO ) in a simpler way. It also allows you to preview the produced PDFs. To use all the powerful features we suggest you also read the txt2pdf documentation and txt2pdf PRO documentation.

How can I customize visual txt2pdf?

If you need to customize Visual txt2pdf or put part of the code inside your applications or simply understand how to interface Acrobat Reader and txt2pdf core, we can sell you the code.
Contact us. (Soon you'l find on line the possibility to buy the code).

How can I use visual txt2pdf?

Simply start up Visual txt2pdf by clicking on the executable. The GUI will automatically be brought up and you should see something similar to this:

Selecting Setting/Options/Format you can see a window similar to this:

set format screenshot

From here, you merely need to change the entries in the GUI to suit your needs, and the PDF will be produced according to your specifications. For instance, should you choose Letter as your default Paper Style, the entry in txt2pdf.cfg will be changed to: (paper: letter). If you do not understand the exact meaning for every field, you can read more about them from the txt2pdf documentation and txt2pdf PRO documentation.
Pay attention: the features Top Margin and Left Margin and Compression Level are available for use only with txt2pdf PRO.

Selecting Setting/Options/Layout you can see a window similar to this:

set layout screenshot

The 'Layout Options' tag will allow you to change things like the default temporary directory as well as other features that are available in txt2pdf and txt2pdf PRO. Please read the txt2pdf documentation and txt2pdf PRO documentation for more information.

Selecting Setting/Options/Properties you can see a window similar to this:

set properties screenshot

Selecting Setting/Options/Mail & FTP you can see a window similar to this:

set properties screenshot

Add the files you want using:

  • File/Add File: to add a single file (remember we suggest you the extension .txt but you can select every textual file and convert it) or you can use files drag and drop
  • File/Add Folder: to add every file in the selected folder and in every its subdirectory (remember we suggest you the extension .txt but you can select every textual file and convert it)

Select the files you want to convert (if you need to reuse this list you can save it File/Save List and reuse it using File/Load List), and click Create PDFs. Now you can find the created PDFs in the Output box. If you click on a PDF file you can see it with the Adobe Acrobat plug-ins, providing that you have them installed.

Scheduler

Click on Scheduler and then on Add you can select the list of files you've before saved (.tsk) and schedule it to the date and the time you want.
The .tsk syntax is very simple: it's a sequence of PDFs with their absolute path (one for line).
You can create this file also directly from your application.

Can the use of visual txt2pdf substitute the use of txt2pdf or txt2pdf PRO?

No, it cannot. Visual txt2pdf is merely a frontend application to make the use of txt2pdf and txt2pdf PRO that much simpler for our users. With Visual txt2pdf, you're afforded an easy way to use all of txt2pdf and txt2pdf PRO's features.

What is new in this version?
  • XP support
  • A better GUI
  • Files Drag and drop
  • Mail & FTP Option part
Possible Problems

At the moment, visual txt2pdf only understands the txt2pdf.cfg it has directly created.

Visual txt2pdf is a trademark of SANFACE Software© 2004.

mailto:sanface@sanface.com | WAP http://www.sanface.com/wap/
http://www.sanface.com | I-mode http://www.sanface.com/i/


txt2pdf explorer features

The txt2pdf self-extracting Windows distribution is made using NSIS (Nullsoft (SuperPiMP|Scriptable) Install System).
Now, with a simple click, you can install and uninstall txt2pdf.
After txt2pdf installation, open your explorer and select a text file (with extension .txt). Click with the right button of the mouse: you can find a new label "Convert to PDF"!.
Run it means to covert your text to PDF using txt2pdf with the default configutions inside the file txt2pdf.cfg.
Obviously you can select more than one file.

In Association with amazon.com

Problems
How can I change the default parameters?
If your default txt2pdf install dir is C:\Programs\txt2pdf and your file is D:\YourDirectory\YourFile.txt, using "Convert to PDF" feature you simply run C:\Programs\txt2pdf\txt2pdf.exe -conf C:\Programs\txt2pdf\txt2pdf.cfg D:\YourDirectory\YourFile.txt
To change the default parameters you have to edit the file C:\Programs\txt2pdf\txt2pdf.cfg
How can I use the same feature with file extensions different from .txt?
You can modify the default parameters using RegEdit or uninstall txt2pdf, modify txt2pdf.nsi inside the distribution, install nsis and create a new txt2pdf distribution with your rules.

txt2pdf is a trademark of SANFACE Software© 2004.


log2pdf: an example to use txt2pdf to convert pix and netscreen log files to pdfs

by SANFACE Software

Index

  • What is log2pdf?
  • PIX example
  • NetScreen example

What is log2pdf?

log2pdf is not a new product. Simply it's a new idea to use txt2pdf family products (txt2pdf, txt2pdf PRO and txt2pdf PRO +crypt).
Every appliance, every application can make a log file. A log file is usually a text file with specific tags to notify errors, warnings, etc.
We have selected 2 special examples (2 logs of 2 firewalls: PIX of Cisco and NetScreen) to show you how you can simply convert logs to pdfs, marking the errors, the warnings and every special tag using standard regular expressions.

PIX example

We have used this simple example with few log lines:

Feb 4 23:57:54 gw.foobar.com %PIX-4-106023: Deny udp src outside:xxx.xxx.146.12/2523 dst inside:xxx.xxx.10.2/1434 by access-group "outside_acl"
Feb 5 07:38:50 10.87.62.40 %PIX-5-304001: 10.5.5.1 Accessed URL xxx.xxx.10.2:/aharrison@awod.com?on_url=http://xxx.xxx.10.2/scripts/..%%35c../winnt/system32/cmd.exe?/c+
%PIX-5-111001: Begin configuration: console writing to memory
Dec 19 04:40:54 gw.foobar.com %PIX-4-400027: IDS:3041 TCP SYN+FIN flags from xxx.xxx.146.23 to xxx.xxx.10.2 on interface outside

We have used colour.cfg to mark with special colours every line that has a pecial %PIX mark:
^.*%PIX-4-106023.*$;0:0:1
^.*%PIX-5-304001.*$;1:0:0
^.*%PIX-4-400027.*$;0:1:0
This syntax use standard regular expression. The first line means: mark rgb (0,0,1) blue the line that start (^) with one or more chars (.*) and %PIX-4-106023 (the special marker) with one or more chars (.*). $ means end of line.
The final Pix pdf

NetScreen example

This is a similar example of a NetScreen log:

Feb 5 19:39:42 10.1.1.1 ns25: Netscreen device_id=00351653456 system-notification-00257(traffic): start_time="2003-02-05 19:39:04" duration=0 policy_id=320001 service=1434 proto=17 src zone=Untrust dst zone=Trust action=Deny sent=0 rcvd=40
Feb 5 19:39:42 10.1.1.1 ns25: Netscreen device_id=00351653456 system-notification-00257(traffic): start_time="2003-02-05 19:34:44" duration=1 policy_id=0 service=http proto=6 src zone-Trust dst zone=Untrust action=Permit sent=11903 rcvd-31454 src=10.5.5.1 dst=xxx.xxx.10.2 src_port=1254 dst_port=80 translated
Feb 7 14:37:30 10.1.1.1 ns25: NetScreen device_id=00351653456 system-warning-00515: duration=0 start_time="2003-02-07 14:37:04" netscreen: Admin User "netscreen" logged in for Web(https) management (port 443) from 12.146.232.2:3473. (2003-02-07 14:34:32)
Feb 7 14:41:33 10.1.1.1 ns25: NetScreen device_id=00351653456 system-information-00767: duration=1 start_time="2003-02-07 14:40:04" netscreen: The system configuration was saved by admin -netscreen-. (2003-02-07 14:38:30)

The rules we have used are very similar to the previous example:
^.*system-.*00515.*$;0:0:1
^.*system-.*00767.*$;1:0:0
The final NetScreen pdf

log2pdf is a trademark of SANFACE Software 2004.
Your technology glasses. We help you see your full potential.
sanface@sanface.com
http://www.sanface.com/


txt2pdf.cgi

Developed by SANFACE Software
Version 3.0 25th January 2001

What is txt2pdf.cgi?

txt2pdf.cgi is a very flexible cgi-bin application based on the powerful txt2pdf tool. With version 3.0 you can find it included inside the txt2pdf standard distribution. txt2pdf.cgi is only a cgi example, you can use it or customize it to suit your needs. Obviously if you plan to keep using it, you need to register txt2pdf.

View the power of txt2pdf.cgi on the net!

In Association with amazon.com

Installation

The install of txt2pdf.cgi installation isn't as simple as that of txt2pdf itself.
You need to install the following along with your web server:
  • PERL5 or Activestate PERL5
  • CGI.pm module
  • Mime::Lite module (this module requires you have sendmail on your web or you can use another sendmail installation)
You need to configure these variables inside the txt2pdf.cgi code:
  • $dirpath/$dirhome/ is the path used by txt2pdf.cgi for all it's configuration files.
  • $sendmail the sendmail host used by txt2pdf.cgi application (Default is localhost).
  • $Counter_file the counter file (remember the user of the cgi needs to have the privilege to write it).
  • $intext the files where the cgi writes the input text (remember the user of the cgi needs to have the privilege to write it).
  • $cfg_file the file where the cgi writes the configuration txt2pdf.cfg file (remember the user of the cgi needs to have the privilege to write it).
  • $outpdf the files where the cgi writes the output pdf (remember the user of the cgi needs to have the privilege to write it).
  • $pdfurl the URL of the output file (remember the user of the cgi needs to have the privilege to write it)
Why do you use the trick that txt2pdf.cgi doesn't produce directly a PDF file but writes it on a web directory and send to the user browser an HTML with inside a link to the correct PDF?
When a cgi application generates directly a PDF file, some browsers can't understand it's a PDF. (Any other suggestions are welcome).

Test

You can test every cgi application made with CGI.pm from command line. (Read the CGI.pm documentation).
e.g. perl txt2pdf.cgi
If the test is good, move the txt2pdf.cgi application in your cgi directory (remember to give it the permission of execution).
http://www.yourcompany.com/cgi-bin/.../txt2pdf.cgi
without parameters will generate a HTML form.
To have better performances save it and and personalize it.

What's new

  • txt2pdf.cgi is now inside the standard txt2pdf distribution
  • New license: txt2pdf.cgi code is freeware. You can completely modify it.
txt2pdf.cgi is a trademark of SANFACE Software© 2004.


awards

txt2pdf awards
txt2pdf rate at Tucows Office (95/98, NT, 2000, ME, XP, 2003) is 3 Cows!

5 cows txt2pdf rate at Tucows Macintosh, LinuxBerg, EPOC and BeOS is 5 Cows!

txt2pdf is Muy Bueno !Muy Bueno! at Softonic Macintosh, Softonic Linux and Softonic Windows

txt2pdf was popular at CNET Download.com More than 20,000 downloads!

txt2pdf is 4.5 4.5 stars at pdf-worker

txt2pdf is 5 and pick at BrotherSoft

txt2pdf is 5 and Editor's Pick at softlandmark.

txt2pdf rate at TopShareware.com is 5 Stars!

TopShareware 5 stars rating

Links to txt2pdf (English language sites)

  • TuCows Windows, Macintosh, Linux, BSD, BeOS and EPOC
  • FreshMeat
  • Simtel.Net
  • VersionTraker
  • DownLoad32
  • Top Downloads
  • PcShareware.net
  • Softsia
  • DownloadsArea.com
  • SofoTeks.com
  • Go2Download
  • FileNode
  • BullDownload
  • Biz2Consumer
  • Canal Software
  • Downloads.be
  • Download3000
  • Euro Download
  • soft2share
  • TrialFiles.com
  • WindowsMirror
  • ScriptFreebies.com
  • WinSW.com
  • HandyArchive.com
  • sw-files.com
  • Software Hypermarket
  • Canistota Software
  • Software Knowledge Base
  • DownloadTip
  • Download Junction
  • Softs.info
  • FindSoftware.com
  • Download5000.com
  • FilesClub.com
  • SprintDownload
  • Downloads Files
  • 4 Software Downloads
  • Amerifling Software
  • The XP corner
  • www.sharewarehunter.com
  • 3D2F.com
  • FlyingMonkeyStick.com
  • DiamondLastForever.com
  • FileOasis.com
  • Bob's Software Pick
  • Soft20.com
  • Retailer Deals
  • Vadino.com
  • ProgramJunction
  • CuteApps
  • FreewareArea.com
  • 01-download.com
  • software in search
  • FileArcade.com
  • Maxx Download new
  • Ware23 new
  • www.acidfiles.com new
  • ishow new
  • Justdosoft.com
  • EfreeDown.com
  • AppDown.com
  • 5Cup
  • SharewarePost.com
  • DownloadChoice.com
  • Windows-Software.com
  • Geek Files
  • File Buggy
  • Downloads Plaza
  • GoLoads
  • Hidownload.com
  • SoftsList.com
  • itLocation.com
  • SoftwareHat.com
  • 5starshare.com
  • Shareware Shuttle
  • DaolnwoD.com
  • FreeFilesZone.com
  • SplashWeb
  • FilesArchive.com
  • www.download-software-freeware.com
  • SubmitFile.com
  • ThunderWare
  • ExeFiles.com
  • WinSite
  • GimmeFiles.com
  • 1000 files
  • Shareware Junction
  • SoftViewer
  • Soft14.com
  • Shareware21.com
  • BrotherSoft Downloads
  • TopShareware.com
  • SoftPedia.com
  • Global Shareware
  • Popular Shareware
  • Red Hot Files
  • SoftAward.com
  • ProgramURL.com
  • Final Download
  • Miseajour.net
  • File Cart
  • digital-sea.com Downloads
  • 200SharewareLinks.com
  • SharewareBox.com
  • Download2you.com
  • nm2
  • SoftCities.com
  • OneKIT
  • jump-to.com shareware
  • Download.E-Not.Net
  • Discount Software downloads
  • Soft411.com
  • Perfect Downloads
  • ShareLibrary
  • FindSoftOnline
  • File Hungry
  • FreeBizFiles
  • 4Convert
  • DownloadPipe.com.au
  • Download-By.net
  • Shareware Downloads
  • SharewarePlanet
  • Software Mirror
  • File Turf
  • FileProfile.com
  • Softizer
  • Most Shareware
  • GetSomeSoft.com
  • Downloads Chicago Sun-Times
  • MightyFiles.com
  • Vonna.com
  • 1000apps.com
  • Home Shareware
  • FindApp
  • tePlanet
  • Hot Shareware
  • FreeFunFiles.com
  • SharewareRiver
  • Best Software Downloads
  • NOVARM shareware
  • Shareware King
  • PeachSeed Software
  • Greg's Software Archive
  • MillionSkies
  • UKwares.com
  • The Shareware Tree
  • Download 4 You!
  • Soft32.com
  • Softforall
  • SwiftCD
  • NetWORLD Software
  • WorldSSP.net
  • 2HaveIt.com
  • EZGoal
  • Grassheap
  • Go-download.com
  • Softpicks
  • AB-Archive.com
  • NewFreeware.com
  • CADloads
  • WinArchives
  • ProgramFiles.com
  • 5 star shareware.com
  • Downloadoholic.com
  • Unitix Shareware
  • File-Archive
  • SAC
  • MyZips.com
  • hitWEB
  • creativepro.com
  • Blue Chillies
  • SoftLandMark
  • Software4Win
  • Softpile.com
  • 5 Star Shareware
  • Icon Today
  • Bill's Software Picks
  • ReviewNow.com
  • Pad Ring
  • Filebasket.com
  • aFreeGo.com
  • FileForum
  • WindowsPC
  • @SoftTop
  • FileGuru.com
  • Download FreeTrial
  • SW-Club
  • Shareware54.com
  • FileClicks
  • Hot Downloads
  • SUN Partner
  • HP OpenVMS
  • CNET Download.com
  • ZDnet Downloads
  • Macintosh Products Guide
  • Inside official OpenVMS FAQ
  • Inside official Cobol FAQ
  • Inside official SGI site
  • Solaris Central
  • Sun Guru
  • Sun solaris freeware
  • Sunfreeware.com
  • The 3000 News Wire Indipendet Information to Maximize your HP 3000
  • Bull's Large Freeware and Shareware Archive for AIX® 4
  • ROOTVG.NET AIX User Platform
  • MPJZ's OpenVMS Resources on the Web
  • OpenVMS.org
  • Tru64.org
  • EnterpriseUnix.org
  • EnterpriseLinux.org
  • RPMfind.net
  • net.sw
  • The T-Systems SfR "Fresh" Software Archive
  • ITtoolbox Portal for SAP
  • ITtoolbox Portal for Oracle
  • ITtoolbox Portal for Baan
  • ITtoolbox Portal for Unix
  • SourceWell
  • The PDFzone
  • pdfzone.de
  • PDFNEWS.DE
  • pdf-worker
  • FM (FileMaker) Pro.org
  • FileMaker World
  • EPOC ZONE
  • Psion Place
  • Pocketland.de
  • www.amiga.org
  • Amigart
  • The RISC OS products directory
  • RISCOS.org
  • NetWarefiles.com
  • Novell Shareware
  • Calogiciel
  • LinuxTracker
  • Gelato :: Software
  • Slaughter House
  • Linux Applications
  • Ice Walkers
  • VLUG
  • MaximumBSD.com
  • Programmers Heaven.com
  • Perl Archive
  • HotScripts
  • NeedScripts
  • ScriptNow!!!
  • PopScripts.com
  • ScriptBiz.com
  • w100w.com/Script
  • Web Development Resources
  • OS/2 Archives
  • OS/2 World.com
  • PDF tool list
  • BuildOrBuy - PDF Resources
  • DOG PILE
  • Linux Weekly News
  • FileWatcher.org
  • Wooven Goods for Linux
  • Linux Gazette
  • Linux Links
  • FirstLinux
  • linux.com
  • Linux/VM
  • ZEAL
  • www.RegSoft.com
  • File Mine
  • LUC DEVROYE'S POSTSCRIPT PAGE
  • Applelinks
  • MacUpdate
  • MacShareware.net
  • All OS X
  • Acquafile
  • Mac OS Archives
  • Mac OS X Apps
  • OSX Zone
  • Info-Mac HyperArchive
  • OSDir.com
  • Google Directory
  • DMOZ
  • Cygwin
  • Vim Online
  • FinancialShareware.com
  • Zaurus Software Index
  • ZaurusDev
  • Xpdf
  • Ghostscript, Ghostview and GSview
Links to txt2pdf (not English language sites)

  • DownloadPro.de (German language)
  • Shareware!de (German language)
  • T-online (German language)
  • amiga-news.de (German language)
  • LOONIX.DE (German language)
  • Fun Time World - Amiga Daily News (German language)
  • WINTIPS.NL (Netherland language)
  • Computertotaal.nl (Netherland language)
  • FOTEXNet.HU (Hungarian language)
  • Terra Software (Spanish language)
  • Softonic Macintosh, Linux and Windows (Spanish language)
  • evprogramas (Spanish language)
  • entreBits (Spanish language)
  • Software Linux (Spanish language)
  • brokenbox.com.ar (Spanish language)
  • Logithèque (French language)
  • Partagiciel Shareware (French language)
  • Megagiciel (French language)
  • Free 'n' Share (French language)
  • Diffuz.com (French language)
  • EpocBoulevar (French language)
  • Superdownloads (Portugese language)
  • Baixaki (Portugese language)
  • Free Code Brasil (Portugese language)
  • VolFTP (Italian language)
  • MyTech (Italian language)
  • DriverItalia.it (Italian language)
  • Software Zone (Italian language)
  • PC Player (Italian language)
  • Mooseek.com (Italian language)
  • ProgrammiGratis.com (Italian language)
  • WindowsUpdate.pl (Polish language)
  • CHIP online (Polish language)
  • programosy.pl (Polish language)
  • IDG.pl (Polish language)
  • Software.Hoga.pl (Polish language)
  • download.net.pl (Polish language)
  • FrazPC.pl (Polish language)
  • Panorama Firm (Polish language)
  • Tietokone
  • MikroPC.net
  • Cuncur.com (Turkish language)
  • Program Arsivi (Turkish language)
  • innDir (Turkish language)
  • WindowsNytt
  • inews24 [Download] (probably Korean language)
  • Simmani (probably Chinese language)
  • Donga (probably Chinese language)
  • Sina (probably Chinese language)
  • NewiHua.com (probably Chinese language)
  • OnlineDown.net (probably Chinese language)
  • 21cn.com (probably Chinese language)
  • Down Tyfo.com (probably Chinese language)
  • HKTK (probably Chinese language)
  • www.DownMe.com (probably Chinese language)
  • pay500 (probably Chinese language)
  • www.xicn.net (probably Chinese language)
  • www.whereyou.com (probably Chinese language)
  • SoftKing (probably Chinese language)
  • TigerCool (probably Chinese language)
  • Soft.Gzrail.net (probably Chinese language)
  • HanaFOS.com (probably Chinese language)
  • Yesterday (probably Chinese language)
  • jsinfo.net (probably Chinese language)
  • superdown.com (probably Chinese language)
  • xiaowu.net (probably Chinese language)
  • 52down.com (probably Chinese language)
  • pdadown.com (probably Chinese language)
  • LinuxAID (probably Chinese language)
  • LinuxByte (probably Chinese language)
  • linux.tcpip.com.cn (probably Chinese language)
  • Shareware Korea (probably Korean language)
  • SoftList (probably Russian language)
  • panvasoft.com (probably Russian language)
  • bsoft-bg (probably Russian language)
  • UFA (probably Russian language)
  • www.ukrUA.com (probably Russian language)
  • OpenNET (probably Russian language)
  • Russian Software Club (Russian language)
  • SOFTPORTAL (Russian language)
  • Unixware.ru (Russian language)
  • SOFT@MAIL.RU (Russian language)
  • faili.murds.lv
  • studna.cz
  • slunecnice.cz
  • web4all
  • AbsbA
new These're the PAD files:
  • perl txt2pdf
  • Windows txt2pdf
txt2pdf is a trademark of SANFACE Software© 2004.


txt2pdf

History of txt2pdf v. 9.2

12/13/2006 version 9.2

  • -test to run a test without conversions

06/19/2006 version 9.1

  • In pagelayout feature we have added support for TwoPageLeft that display the pages two at a time, with odd-numbered pages on the left, TwoPageRight (this feature wil set PDF version 1.5) that display the pages two at a time, with odd-numbered pages on the right

04/25/2006 version 9.0

  • Optimized pdf output

01/10/2006 version 8.5

  • Support for Czech. (If you want different languages or different fonts for the supported languages contact us).

10/24/2005 version 8.4

  • We have added ID: (optional, but strongly recommended from PDF 1.1) a file identifier for the file. Although this entry is optional, its absence might prevent the file from functioning in some workflows that depend on files being uniquely identified. If yu don't want to use ID you can use noid : 1

09/18/2005 version 8.3

  • The automatic conversion of strings with http:// ftp:// mailto: https:// ldap: news: ... into links was one of the first features of txt2pdf.
    We have changed strategy and now this feature is optional, you have to select linkuse : 1.
    The reasons of this choice are two: the link conversion is made using RE and it's very time consuming. This means that with big text files the conversion is slow. The second reason is that Reader 7.x automatically converts into link http:// https:// ftp:// mailto: ... and also www. and @!

06/19/2005 version 8.2

  • You can set an ftp site where put every pdf after text to pdf conversion.
    You can use the follow parameters: ftphost : host.domain.com, ftpuser : user, ftppassword : password, ftpdirectory : directory

04/25/2005 version 8.1

  • Support for Hebrew. (If you want different languages or different fonts for the supported languages contact us).

01/25/2005 version 8.0

  • Support for Greek, Polish and Thai. (If you want different languages or different fonts for the supported languages contact us).

12/13/2004 version 7.6

  • Solved problems with Simplified Chinese and Korean fonts.
  • Minor bug corrected.

09/12/2004 version 7.5

  • To put one or more lines before the beginning of the PDF now you can use inside txt2pdf.cfg prepdf.
    This feature can be very useful. On Xerox printers + DocuSP controller you can use Xerox Job ticket commands. The "options" must be placed at the beginning of the pdf file, before the %PDF. To print duplex you can use
    prepdf: %XRXbegin: 001.0300\n%XRXPDLformat: PDF\n%XRXrequirements: duplex\n%XRXend
    (\n means go to a new line)
    If you need more information about Xerox Job ticket or how to configure it don't hesitate to contact us.
    Pay attention: accordingly with PDF Specification 1.5 (specifically - Implementation Notes 13 and 14) PDF Header in form "%PDF-M.m" or "%!PS-Adobe-N.n PDF-M.m" should appear somewhere within the first 1024 bytes of the file. We suggest you to use this feature only to print the pdf!
  • If you use email txt2pdf feature with priority now you can set the email priority. The default 3 means X-Priority: 3 (Normal) and X-MSMail-Priority: Normal. You can use also 1 X-Priority: 1 (Highest) and X-MSMail-Priority: High or 5 X-Priority: 5 (Lowest) and X-MSMail-Priority: Low

06/19/2004 version 7.4

  • With Japanese, Korean and Chinese (traditional and simplified) fonts we have set that every ascii chars is just half of an Asian char (Japanese, Korean, traditional and simplified Chinese).
    This allows to convert this Japanese text into this pdf or this traditional Chinese text into this pdf!
    If you need a different set, contact us and explain us your problem, we'll solve your problem!

04/25/2004 version 7.3

  • If inside a line of your textual report txt2pdf will find the special underline mark (the mark you have specified with underline option) the rest of the line will be write at the begin of the same line.

03/15/2004 version 7.2

  • email notify option: the possibility to set the email where you want to receive the notify of email reading.
  • mail_body_file option: the possibility to specify an external file that contains the email body.
  • New Windows GUI Visual_txt2pdf.

01/25/2004 version 7.1

  • You can put the design and text part you usually use in the bgdesign in an EPD file. The advantage is that you have a more optimize pdf.
  • The Windows installer now can install the txt2pdf documentation (Windows help format) via internet.
  • You can verify every distribution with an MD5 file.
10/24/2003 version 7.0
  • Email support: the possibility to send the produced pdf via email (like pdf attach). You can use a remote smtp site or local sendmail or similar programs.
  • For every Korean, Japanese, simplified Chinese and traditional Chinese font now you can select italic, bold and bolditalic
09/18/2003 version 6.7
  • With annotationtext you can introduce the text you want to put in the annotation on the first page of your document.
  • More information with -verbose option.
06/19/2003 version 6.6
  • It's possible to set the PDF version (default is 1.2).
  • txt2pdf.vim update (vim plug-in to convert using vim text into pdf).
  • New NSIS contributed directory where you can find the txt2pdf.nsi configuration file we use to create the Windows Self Extracting EXE distribution with NSIS.
04/25/2003 version 6.5
  • Stephan Hegel helps us to support Simplified Chinese in GB encoding (STSong GB-EUC-H)
  • chinese is now tradchinese
02/25/2003 version 6.4
  • inputmod and outputmod features: to use external applications to modify the txt2pdf input files or to move the txt2pdf output files (pdfs)
  • Visual txt2pdf 3.0
01/10/2003 version 6.3
  • Korean support: HYSMyeongJoStd KSCms-UHC-H normal and bold
  • An updated FAQ 1.4.
12/13/2002 version 6.2
  • chinese font support
  • Better Windows installation GUI
10/24/2002 version 6.1
  • New pagemark feature to open the PDF inside your browser at the page you prefer using the URL http://your_site.your_ext/your_pdf_document#pagen where n is the number of the page e.g. http://www.sanface.com/pdf/test.pdf#page2
  • New Windows installation GUI
  • Windows Help and html documentation
09/18/2002 version 6.0
  • Support for HeiseiMin-W3-90ms-RKSJ-H (/F20) and HeiseiKakuGo-W5-90ms-RKSJ-H (/F21) Japanese fonts
  • Support for JISB4 and JISB5 Japanese paper formats
  • You can select in txt2pdf.cfg one of the 16 supported fonts.
  • You can use one of the 16 supported fonts with fontmark.
  • HTML 4.01 validated documentation (HTML Validation Service).
06/19/2002 version 5.8
  • zoom feature: to set the open of first page with the selected zoom.
  • txt2pdf.vim 2.4 inside contributed directory: VIM plugin to save and convert the edited text to PDF clicking a button!
05/10/2002 version 5.7
  • Corrected a little bug into date info (thanks David Norman).
  • txt2pdf.vim 2.0 inside contributed directory: VIM plugin to save and convert the edited text to PDF clicking a button!
  • Visual txt2pdf 2.2
03/25/2002 version 5.6
  • New linear option or inside your configuration file: list. With this new option you can specify a list file with inside a list of your input textual files (one entry every line).
  • New executable version for Mac OS X.
01/25/2002 version 5.5
  • New rules inside txt2pdf.cfg. Now you can simply put the right string inside wrong frase. E.g. with paper you can use "A4", "a4" but also "A4 " or "A4WhatYouWant"
  • Explorer features with Windows self-extracting distribution.
  • FAQ upgrade.
  • bzip2 compressed Windows self-extracting distribution.
12/13/2001 version 5.4
  • ViewerPreferences option: with the possibility to hide Toolbar, Menubar, WindowUI and the possibility to set FitWindow and CenterWindow.
  • fit option: display the page designated, with its contents magnified just enough to fit the entire page within the window both horizontally and vertically.
10/24/2001 version 5.3
  • Now the text can contain Mac EOL (end of line) (\r), Windows EOL (\r\n), Unix EOL (\n).
  • Windows installer and unistaller.
  • Visual txt2pdf 2.1.
  • FAQ.
09/18/2001 version 5.2
  • Now you can execute txt2pdf without txt2pdf.cfg. It'll use the default parameters. The program will advice you but it doesn't abort the execution.
  • -default to print the default parameters
07/20/2001 version 5.1
  • New example using the power of EPD. Send us your EPD files to put them into an 'on line' EPD library!
  • Visual txt2pdf 2.0 inside the Windows distribution.
  • minor fixes
06/19/2001 version 5.0
  • We've deleted the print in the first line of title or text file name.
  • It's possible to re-run infinitely (every configured second, sleep feature) txt2pdf on a specific directory (and also its recursice subdirectories) moving the produced PDFs in a specific directory and the original text in a specific directory.
  • -current the program version
04/25/2001 version 4.6
  • We've corrected a possible bug with Acrobat Reader 5.x and the PDF made by previously txt2pdf releases. Now inside the layer you've got to put your text commands inside BT and ET
02/25/2001 version 4.5
  • Euro compliance
  • Text to PDF generation using a standard SCO lp command by Gavin Jackson
  • Validated HTML 4 documentation
  • PAD files: perl txt2pdf and Windows txt2pdf
  • minor bugs
02/25/2001 version 4.4
  • pdfindex 3.0, now it's free code in the contributed zone.
  • CreationDate now has the time zone information.
  • With verbose (-v) you can now obtain the PDF generation time for every processed file.
01/25/2001 version 4.3
  • It's not possible to convery Windows files with blanks inside the name or blanks inside the path.
  • txt2pdf.cgi 3.0, is now free code in the contributed zone.
  • PostScript To EPD is an on line converter from PostScript graphic file to EPD (a new encapsulated vectorial graphic format). In the same time you can convert your PostScript graphic also to PDF, TIFF, JPEG.
    We'd like to make a gallery with the best EPD: help us sending us your best EPD!
  • Visual_txt2pdf 1.2 is now inside the Windows distribution
12/13/2000 version 4.2
  • rotate feature
  • pstoepd: with this contributed program you can now convert a PostScript design to EPD. See the PostScript tiger inside a PDF document
  • Visual_txt2pdf 1.1 is now inside the Windows distribution
11/1/2000 version 4.1
  • EPD 1.0 support. You can use EPD inside background layer. See the nice example!
09/19/2000 version 4.0
  • colour file feature: with a configuration file you can mark coloured phrases (every colour you want using the rgb PDF syntax), using PERL regular expression, frases in the produced PDF files
  • fontmark file feature: with a configuration file you can mark bold or italic or bolditalic frases in the produced PDF files
  • cols, columns2 and allowinparse aren't supported with the new 4 version
  • New fee: $85
07/10/2000 version 3.6
  • withextension feature to don't change the file default extension with .pdf (simply txt2pdf will create new PDFs appending .pdf to the original name)
  • Lotus Notes note in the contributed directory by Charles Daniel
  • MPEiX note in the contributed directory about spoolfiles by Mark Bixby
06/19/2000 version 3.5
  • Inside txt2pdf.cfg it's possible to use #!ENV#...#!/ENV# to specify environment variables
  • The link box algoritm with Courier font is now correct
  • HP MPE/iX 6.0: tested by Mark Bixby with Perl 5.6.0 (the author of Perl/iX for HP e3000 MPE page).
05/15/2000 version 3.4
  • Encoding support: WinAnsiEncoding, MacRomanEncoding, MacExpertEncoding, PDFDocEncoding and the Unix default
  • Cyrillic note in the contributed directory from Ilya Naumov
04/25/2000 version 3.3
  • Full Screen page mode support
  • Possibility to select the page layout from Single Page (deafult), One Column, Two Column Left, Two column Right
03/10/2000 version 3.2
  • All the transaction effects supported by PDF format: split, blinds, box, wipe, dissolve, glitter
  • STDIN and STDOUT support
01/25/2000 version 3.1
  • Dissolve transaction effect support
  • Deleted lf_extra feature: now you can convert e.g. on Linux textual document from Unix, Windows, Mac.
  • Text-Flowchart: an 'ASCII Flowchart maker' perl module created by Jim Thomason
  • Tested on HP-UX 10.20 by Dierk Laub
01/01/2000 version 3.0
  • Background and foreground layer support.
    You can create a layer under and up your text, where you can insert frases or designs (usign PDF syntax)
  • new paper format support: tabloid, ledger, legal, statement, executive
  • TXT2PDFCFG environment variable
  • Tested on SCO Unixware 7.0 by Zyle, Algis J
  • Tested on FreeBSD 4.0 by Ilya Naumov
12/13/1999 version 2.5
  • you can create a link to a specific page within a PDF document http://...pdfdocument#pdfmark
    Read this good documentation
  • POD documentation [a suggestion of Jerome Lauret]
  • OpenVMS contributed directory
  • Amiga and Acorn-risc suggestion [from Joern-Erik LEO Burkert]
  • !txt2pdf a RiscOS frontend for txt2pdf [from Joern-Erik LEO Burkert]
    Requires: JFSharary by Justin Fletcher, !Perl for RiscOS and txt2pdf
    You can find it in the contributed/Acorn-Risc directory or directly at LEO's RisOS-page
11/01/1999 version 2.4
  • Mac OS support [from Christian Huldt]
  • BeOS support [from David Cantrell]
09/18/1999 version 2.3
  • txt2pdf is able to handle ascii or latin1 documents formatted for typewriter-like devices. These texts (as e.g. produced by "groff -Tlatin1") contain bold characters represented by the sequence 'CHARACTER BACKSPACE CHARACTER' and italics using the sequence '_ BACKSPACE CHARACTER'. Reverse ('ESC-7') and half reverse ('ESC-8') line feeds are unusual but could appear in rare cases. They should be removed prior to processing with txt2pdf. [from Soenke J. Peters]
  • OpenVMS support [from Dave Smith]
  • Documentation about Year 2000 Compliance
07/20/1999 version 2.2
  • URL support (https: file: ldap: news:)
06/19/99 Version 2.1:
  • every word like mime:... will become a link that launch the correct application and opens the file [from Eric Wagner]
    Examples of file specifications
    System | System-dependent | path Written as ...
    DOS | ..\pdfdocs\spec.pdf (no drive) | mime:../pdfdocs/spec.pdf
    DOS | r:\pdfdocs\spec.pdf | mime:/r/pdfdocs/spec.pdf
    UNIX | /user/fred/pdfdocs/spec.pdf | mime:/user/fred/pdfdocs/spec.pdf
    UNIX | pdfdocs/spec.pdf (relative) | mime:pdfdocs/spec.pdf
04/25/99 Version 2.0:
  • Border line
  • URL support (mailto: http: ftp:)
  • Allowinparse option [from Matt Johnson]
    At the moment the options aren't multiline
    [!yellow][!/yellow]
    [!red][!/red]
    [!green][!/green]
    [!blue][!/blue]
    [!italic][!/italic]
    [!bold][!/bold]
  • Bugfix: added support for landscape option inside configuration file
  • End of txt2pdf_opt support
02/08/99 Version 1.3:
  • Added recursive option using File::Find module
  • Added match option. Now you can select the files you want find with recursive option (e.g. *.pdf, a?.*)
  • Added blue color
  • Added A5 paper format
  • Now multiple file selection with metachars (e.g. *.txt) works correctly [from Charles Wilt]
12/13/98 Version 1.2:
  • Added page number option
  • Added BeginFile and EndFile option
09/19/98 Version 1.1:
  • Minor bugfix
    • mark italic
    • If txt2pdf wraps the text, then sometimes, txt2pdf inserts a space at the beginnings of lines.
    • Some of the lines run off the right hand edge of the page
  • All the options in the configure file are now also line options in txt2pdf_opt (necessary to use txt2pdf in a cgi-bin) [from Eric Lease Morgan]
  • Added -2 option to convert text in 2 columns PDF
06/19/98 Version 1.0
First public release

txt2pdf is a trademark of SANFACE Software© 1998-2006.

SANFACE Software


txt2pdf PRO: to convert text (textual report) into pdf

txt2pdf PRO

Developed by SANFACE Software.
Version 9.2 13 December 2006

Contents
  • What is txt2pdf PRO?
  • Why do you need txt2pdf PRO?
  • Getting txt2pdf PRO, License and Registration
    • Upgrade policy
    • Volume discount
    • Reseller Discounts
    • No limit licence
  • Installing txt2pdf PRO
  • Syntax
  • Form Feed
  • txt2pdf PRO + crypt support
  • pdfcrypt to set permissions to your PDF archive
  • Books about PDF

In Association with amazon.com

What is txt2pdf PRO?

txt2pdf PRO 9.x is a very important release in the evolution of txt2pdf 8.x PRO and is the PRO version of txt2pdf 9.x. We distribute txt2pdf PRO only in executable binaries, but under special circumstances, source code can be provided. This binary-only outlook makes it easier to install, and simpler to use. You don't need Perl, nor any of the Perl modules or libraries. There are also new exciting features in the PRO version that are not available in the regular version. Your old textual reports will become very pleasing graphical PDF reports. Your applications can simply harness and integrate the power of txt2pdf PRO.

Why do you need txt2pdf PRO?

txt2pdf PRO offers you all the features of txt2pdf 8.x plus these important features:

  • compress to make compressed pdf and compress_level to set the compression level new
  • optimize to make an optimize pdf code new
  • Form Feed (^L) support
  • -skip1ff option to skip the first form feed
  • the possibility to set the top and left margins
  • Using inside the text, at the begin of a new page (e.g. after the form feed) the marker #!landscape# you can force the single page to become landscape.
  • inside layers (background and foreground) you can use the same txt2pdf features plus
    #!image#;;;;;;;;#!/image# to add RGB jpeg images
    #!link#;;;;#!/link# to add links
  • embedded true type font support (see the linedraw and barcode example)
  • outline feature to set in outline.txt the rules for bookmarks new
  • Setting mainframe : 1 you can simply convert textual mainframe reports. At the moment this feature support in the first column 0, 1, -, +. If you need other support contact us. new
  • You can use colours, fonts, links, etc with your personal or standard tags
  • begin1 to change the background of the first page and bgdesignlast to change the background of the last page
  • the possibility to set the position (x,y) of the annotation icon in the first page.
  • possibity to ask an executable with outside the libraries (to support multitasking). new
Getting txt2pdf PRO, License and Registration

txt2pdf PRO is a PERL tool.
We distribute only 6 executable versions: Windows, Linux, Solaris, HP-UX, AIX, Mac OS X.

The Windows executable version has inside Visual txt2pdf : a VB graphical user interface new

You can freely redistribute txt2pdf PRO tool in its unregistered archive format (zip or tar.gz) You may request other UNIX executables (Linux like Slackware and Caldera, Linux on mips, OSF/1 (Tru64), FreeBSD, BSD/OS, OpenBSD, IRIX) or the original PERL code.
In the event that we send you the original perl code:
You can't modify directly it.
You can't resell txt2pdf or a modify version of it without SANFACE Software authorization.
You can't copy part of it to include in your source without SANFACE Software authorization.
We trust you.

The txt2pdf PRO Windows executable (Self Extracting EXE file)
The txt2pdf PRO Windows executable .zip
The txt2pdf PRO Linux executable .tar.gz
The txt2pdf PRO Solaris executable .tar.gz (if you need an executable version for old Solaris release Send us an email)
 The txt2pdf PRO AIX executable .tar.gz
The txt2pdf PRO HP-UX executable .tar.gz (if you need an executable version for hp-ux 10.x Send us an email)
The txt2pdf PRO Mac OS X executable .tar.gz
         get txt2pdf

The registration fee is

  • $990 (US) for 1 CPU computer
  • $1190 (US) for 2 or 3 CPU computers (or dual-core)
  • $1440 (US) for 4 to 7 CPU computers
  • $1740 (US) for 8 to 15 CPU computers
  • $2090 (US) for 16 to more CPU computers
for every server installation.

Description | Payment Options
Register NOW txt2pdf PRO via a SECURE SERVER at www.RegSoft.COM | Payment options include Credit Card, FAX Ordering, Postal Mail, Phone, Purchase Order. Register txt2pdf PRO now!

UPGRADE POLICY

You can upgrade txt2pdf PRO 6.x, 7.x, 8.x to the new version with the discount of the amount you previously paid + a fix fee for every license:

  • $200 for 8.x
  • $300 for 7.x
  • $400 for 6.x
For example, if you paid $850 for your 5.x copy of txt2pdf PRO and the new version costs $990, you will pay $990 - $850 + $350 = $490.
If you registered a previous release (1.x, 2.x, 3.x, 4.x) you have to buy a new license.
Contact us via email at sanface@sanface.com for more information on how to upgrade your version.

VOLUME DISCOUNT

4-10 | $900 each (no CPU server difference)
11-100 | $750 each (no CPU server difference)

RESELLER DISCOUNT
Contact directly us! We're looking for resellers and partnerships.

NO LIMIT LICENCE
You've one or more products with a lot of installations and you want to put txt2pdf inside your every tool. This is the licence you're looking for. Its costs: $45000 + 20 % every year. Obviously you'll receive every update freely.

Installing txt2pdf PRO

Here we'll describe only the new features of the PRO version. If you don't know about the txt2pdf 8.x features, please read this.

Inside txt2pdf.cfg or your configuration files these are the new fields: topmargin, leftmargin, bgdesign1, bgdesignlast, bgdesign1no, fgdesign1, colour, fontmark, link, outline, npagex, npagey, compress, compress_level, rotate, optimize, annotationtext, annotationx, annotationy, inputmod, outputmod, mainframe.

The layer features are:

  • bgdesign background layer in every PDF page
  • bgdesign1 background layer only in the first page
  • bgdesignlast background layer only in the last page
  • bgdesign1no background layer in every page without the first (and the last if begingdesignlast exists)
  • fgdesign foreground layer in every page
  • fgdesign1 foreground layer only in the first page
Inside the layers (bgdesign, bgdesign1, begindesignlast, bgdesign1no, fgdesign, fgdesign1) you can use directly the PDF syntax to design and to write, you can import JPEG image, you can use links.

These are a few examples to explain how you can write or design directly with PDF syntax:
If you want to put on every generated page a bold big diagonal DRAFT, you can use the foreground file with
REMBER to put the text instruction inside BT and ET

      BT
      /F3 55 Tf
      .5 .5 -.5 .5 150 455 Tm
      (DRAFT) Tj
      ET
/F3 means use the bold Courier font, 55 is the point size.
The meaning of the first line is: use the bold Courier font with point size 55.
The meaning of the second line is: start form point (150,455) and write diagonal.
The meaning of the third line is: write DRAFT.
The default font value is /F1 (normal Courier). You may also use these 14 PDF default fonts:
  • /F1 normal Courier
  • /F2 italic Courier
  • /F3 bold Courier
  • /F4 bolditalic Courier
  • /F5 normal Helvetica
  • /F6 italic Helvetica
  • /F7 bold Helvetica
  • /F8 bolditalic Helvetica
  • /F9 normal Times
  • /F10 italic Times
  • /F11 bold Times
  • /F12 bolditalic Times
  • /F13 Symbol
  • /F14 ZapfDingbats
these 8 japanese fonts (remember to set japanese : 1):
  • /F20 HeiseiMin-W3-90ms-RKSJ-H
  • /F21 HeiseiMin-W3-90ms-RKSJ-H italic
  • /F22 HeiseiMin-W3-90ms-RKSJ-H bold
  • /F23 HeiseiMin-W3-90ms-RKSJ-H bolditalic
  • /F24 HeiseiKakuGo-W5-90ms-RKSJ-H
  • /F25 HeiseiKakuGo-W5-90ms-RKSJ-H italic
  • /F26 HeiseiKakuGo-W5-90ms-RKSJ-H bold
  • /F27 HeiseiKakuGo-W5-90ms-RKSJ-H bolditalic
4 traditional chinese font (remember to set tradchinese : 1):
  • /F30 PMingLiU ETen-B5-H
  • /F30 PMingLiU ETen-B5-H italic
  • /F30 PMingLiU ETen-B5-H bold
  • /F30 PMingLiU ETen-B5-H bolditalic
4 simplified chinese font (remember to set simplchinese : 1):
  • /F35 STSong GB-EUC-H
  • /F35 STSong GB-EUC-H italic
  • /F35 STSong GB-EUC-H bold
  • /F35 STSong GB-EUC-H bolditalic
these 4 korean fonts (remember to set korean : 1):
  • /F40 HYSMyeongJoStd KSCms-UHC-H
  • /F41 HYSMyeongJoStd KSCms-UHC-H italic
  • /F41 HYSMyeongJoStd KSCms-UHC-H bold
  • /F41 HYSMyeongJoStd KSCms-UHC-H bolditalic
or the embedded true type fonts you have selected. We suggest you to start them from /F50. It's not simple to configure embedded true type font. We suggest you to test the examples you can find in ETTtests directory (barcode,Cyrillic,linedraw,music) and contact us to costomize different true type fonts.
If you want to design, for instance, a gray background with a black border line, you can use the background file with

      .9 g
      0 G
      3 w
      25 25 545 792 re
      B
The meaning of the first line is: inside the rectangle use gray (0 is black, 1 is white)
The meaning of the second line is: the line is black
The meaning of the third line is: the width of the line is 3
The meaning of the fourth line is: the rectangle is (25,25) (545,792)
The meaning of the fifth line is: design

You can find the information about the PDF syntax you can use in the layers directly in The PDF Reference Manual Version 1.3 (518 pages, ~5 Mb) in the Chapter 8 (Page Descriptions).

To use JPEG images inside layers you need to use this syntax:
#!image#image.jpg;image_width;image_high;z1;z2;z3;z4;x_position;y_position#!/image#
The first field is exact path where txt2pdf PRO can find the image (you can use also relative path)
These are a few examples:
./filename.jpeg
Z:/my_network_directory/file.jpg
The second and the third fields are the exactly width and high dimension of the image (to find it simply you can open the jpeg inside Netscape. It'll display like title the dimension)
4th, 5th, 6th, 7th fields are very powerful and complex. You can use it to scale, rotate the image.
At the beginning we suggest you to use
z1=image_width, z2=0, z3=0, z4=image_width
to scale correct an image to divide or multiple z1 and z4 for the same integer
You can find the information about the PDF transformation syntax in The PDF Reference Manual Version 1.3 (518 pages, ~5 Mb) in the Chapter 3.9.
8th and 9th fields are the x and y position on the page (0,0 the bottom left corner)
To introduce a link this is the syntax
#!link#url_field;x1;y1;x2;y2#!/link#
where the first field is the url
2nd, 3th fields are the left bottom point of the rectangle of the link
4th, 5th fields are the right up point of the rectangle of the link
This is a simple example of an image with a link up
#!image#./stamp150.jpg;113;150;113;0;0;150;470;390#!/image#
#!link#http://www.sanface.com;470;390;583;540#!/link#

Remember when you use the background layers this is the order that every object is displayed:

  1. Images with the order you introduce.
    e.g. if two images have a common area the second image you put in the background layer will cover the common area of the first image
  2. text and designs with the order you introduce over all the images
If you want to put some text or designs under the images you can use text and designs inside the tags
#!bgdesign#
...
#!/bgdesign#
e.g. to make a red background under every images you can use a coloured rectangle with the border of the same colour and the same dimension of the paper

   #!bgdesign#
   1 0 0 rg
   1 0 0 RG
   0 0 792 612 re
   B
   0 G
   0 g
   #!/bgdesign#
Inside the backgound layers you can use also #!year# #!mon# #!mday# #!hour# #!min# #!sec# #!yday# #!wday# #!isdst# to use the computer clock to set year, month ... (you can read the perl manual in the part perlfun: localtime).

If you've created your layers probably you need to move all your text to put it correctly on the page. You can use topmargin and leftmargin to set the starting point of the text in every page.
With annotationtext you can introduce the text you want to put in the annotation on the first page of your document. With annotationx and annotationy you can set the position of the annotation
If you set outline to 1 (default is 0) the final pdf code will be optimezed.
Every Form Feed is automatic converted into a new PDF page
How to configure colour, fontmark, link and outline files.
This is the NEW syntax you need to use inside the file you've defined with the colour variable
string1;string2;string3;number:number:number
(We've added the first 2 field. If you don't use the first 2 fields you've the same effect of the old syntax)
where number is > 0 < 1 (the PDF rgb syntax) or is > 0 < 255 (standard rgb system)
string3 is every string you want to mark with the selected colour
e.g. ;;TOTAL FEDERAL GST ACTIVE;160:40:200
With txt2pdf PRO you can change phrases with all the colour you want.
We use this line to mark blue every link. Obviously you can change it with your perferred colour
;;http://[^ \n]*;0:0:1
;;ftp://[^ \n]*;0:0:1
;;mailto:[^ \n]*;0:0:1
;;mime:[^ \n]*;0:0:1
;;https://[^ \n]*;0:0:1
;;file:[^ \n]*;0:0:1
;;ldap:[^ \n]*;0:0:1
;;news:[^ \n]*;0:0:1
You can use the PERL regular expression
e.g. ;;^Total federal.*active$;.7;.8;.2
You can use the first two fields to set your tags and to delete them and to change the colour to the string inside the third field (remember you can use this syntax only in the same line).
e.g. <blu>;</blu>;#!btag#.*#!etag#;0:0:1
means: the start tag is <blu> , the end tag is </blu> delete the tags an use the 0,0,1 colour (blue) to every word (.*) inside <blu> (#!btag#) and </blu> (#!etag)
X11 and PostScript RGB map
This is the NEW syntax you need to use inside the file you've defined with the fontmark variable
string1;string2;string3;font;pointsize
(We've added the first 2 field. If you don't use the first 2 fields you've the same effect of the old syntax)
where font is one from /F1 to /F14, and pointsize is a number (the dimension of the font)
e.g. ;;TOTAL GRAHAM PIES OLD;/F7;14
This means: change the default font to the bold Helvetica font with point size 14 in every string "TOTAL GRAHAM PIES OLD"
With txt2pdf PRO you can change phrases using the default 14 fonts with every point size.
You can use the PERL regular expression.
You can use the first to fields to set your tags and to delete them and to change the font to the string inside the third field (remember you can use this syntax only in the same line).
e.g. <b>;</b>;#!btag#.*#!etag#;/F5;14
means: the start tag is <b>, the end tag is </b> delete the tags an use the /F5 font with pointsize 14 to every word (.*) inside <b>(#!btag#) and </b>(#!etag#)
This is the syntax you need to use inside the file you've defined with the outline variable
string;page_number string is the text you'll see in the bookmark to jump to the page page_number
This is the syntax you need to use inside the file you've defined with the link variable

  • string;number means: transform the string into a link to the 'number' page
  • string;URL means: transform the string into a link to the URL
  • string;mime:... means: transform the string to a start point to execute the correct program to read the file
    e.g. CIAO:mime:ciao.doc pushing on ciao link will be started Word that will read ciao.doc (this works very good on Windows)
  • string;string2 means: transform the string into a link to the page of the first occurrence of string2
You can use the same syntax also with the link mark inside the layouts.
With npagex and npagey you can set the position on the page of the page number
You can use compress inside the configuration file or if you prefer -compress option.
With compress_level you can set the compression level. Valid values are 1 through 9, (1 Z_BEST_SPEED, 9 Z_BEST_COMPRESSION). 6 Z_DEFAULT_COMPRESSION.
With inputmod you can set a file where txt2pdf PRO will execute the commands in every line on the input text. Using this feature you can create ad hoc filters. e.g. we have made a mainframe.pl filter to convert textual mainframe reports into textual unix (it convert 1 in the first column into form feed, 0 in the first column into \n, ...)
In our example the inputmod file is
perl mainframe.pl #!input#
With outputmod you can set a file where txt2pdf PRO will execute the commands in every line on the input text. Using this feature you can execute external command on the pdf outputs. e.g. you can move the pdfs in a web directory or send them via email or to a fax or ...
Setting mainframe to one you can convert textual mainframe reports. txt2pdf supports in the first column 0, 1, +.
+ in the first column means write the line over the previous line (don't insert a new line). You can use + to make underline and bold.
This is an underline example
undeline
+________
This is a bold example
BOLD
+BOLD

Syntax

txt2pdf [-options] files these are the new options:
-compress | to generate compressed PDF's
-skip1ff | to skip the first form feed
list: with list you can use metacharacters and relative and absolute path name
Form Feed

txt2pdf PRO substitutes every form feed with the exact number of EOL (end of line \n).
This means that if you have set line number to equal 80, if txt2pdf finds the form feed in the line 41, it will substitute the form feed with 40 \n.
The simplest way is to substitute the form feed with the syntax of a new PDF page, but with this way it is very complex to know, like designing the rectangle of links (in PDF a link is a rectangle area on the page around the word or words).
We've chosen the first method.

Our txt2pdf PRO executables are generated by perl2exe tool

txt2pdf PRO is a trademark of SANFACE Software© 2005.
Your technology glasses. We help you see your full potential.
mailto:sanface@sanface.com
http://www.sanface.com/


txt2pdf PRO + crypt and pdf background

Developed by SANFACE Software.
Version PRO v. 9.0 19th June 2006

Contents
  • What is txt2pdf PRO + crypt?
  • Why do you need txt2pdf PRO + crypt?
  • Getting txt2pdf PRO + crypt, License and Registration
    • Upgrade policy
    • Volume discount
    • No limit licence
  • Installing txt2pdf PRO + crypt
  • Syntax
  • Form Feed
  • pdfcrypt to set permissions to your PDF archive
  • Books about PDF

SANFACE Software

What is txt2pdf PRO + crypt?

txt2pdf PRO + crypt 9.x is the standard txt2pdf PRO 9.x distribution + the possibility to encrypt a PDF-file (set permissions, set user and owner password, set 40 or 128 bit encryption).
In version 9.x txt2pdf PRO + crypt support the possibility to use like background a pdf.

Why do you need txt2pdf PRO + crypt?

txt2pdf PRO + crypt 9.x is the standard txt2pdf PRO 9.x distribution + the possibility to encrypt a PDF-file (set permissions, set user and owner password, set 40 or 128 bit encryption).
We distribute txt2pdf PRO + crypt only in executable binaries, but under special circumstances, source code can be provided. This binary-only outlook makes it easier to install, and simpler to use. You don't need PERL, nor any of the PERL modules or libraries. Your applications can simply harness and integrate the power of txt2pdf PRO + crypt 9.x.

  • The reader will not able to read the document without the correct user password. The reader will not able to modify the document without the correct owner password. Acrobat Reader application will prompt to the user the introduction of a password. ( -userpass password -ownerpass password )
  • The reader will not able to copy text and graphics from document. The button to cut the file will be disabled in Acrobat Reader application. ( -no-copy )
  • The reader will not able to print the document. The button to print the file will be disabled in Acrobat Reader application. ( -no-print )
  • The reader will not able to modify contents of document (other than text annotations and interactive form fields) ( -no-edit )
  • The reader will not able to add or modify text annotations and interactive form fields ( -no-notes )
  • -R=2 40 bit encryption, -R=3 128 bit encryption

In version 9.x txt2pdf PRO + crypt support the possibility to use like backgrouna a pdf.
This is the syntax you can use in bgdesign is very similar to the image syntax:
#!pdf#file-name.pdf;z1;z2;z3;z4;x_position;y_position#!/pdf#

The first field is exact path where txt2pdf PRO + crypt can find the pdf (you can use also relative path)
These are a few examples:
./filename.pdf
Z:/my_network_directory/file.pdf
2nd, 3rd, 4th, 5th fields are very powerful and complex. You can use it to scale, rotate the pdf.
At the beginning we suggest you to use
z1=1, z2=0, z3=0, z4=1
to scale correct an image to divide or multiple z1 and z4 for the same integer
6th and 7th fields are the x and y position on the page (0,0 the bottom left corner)

Getting txt2pdf PRO + crypt, License and Registration

txt2pdf PRO + crypt is a PERL tool.
We distribute only 5 executable versions: Windows, Linux, Solaris, HP-UX, AIX.

The Windows executable version has inside Visual txt2pdf a VB graphical user interface. This software is old and we don't suggesto to use it.

You can freely redistribute txt2pdf PRO + crypt tool in its unregistered archive format (zip or tar.gz) You may request other UNIX executables (Linux like Slackware and Caldera, Linux on mips, OSF/1, FreeBSD, BSD/OS, OpenBSD, IRIX) or the original PERL code.
In the event that we send you the original perl code:
You can't modify directly it.
You can't resell txt2pdf or a modify version of it without SANFACE Software authorization.
You can't copy part of it to include in your source without SANFACE Software authorization.
We trust you.
The txt2pdf PRO + crypt Windows executable .zip
The txt2pdf PRO + crypt Linux executable .tar.gz
The txt2pdf PRO + crypt Solaris executable .tar.gz
The txt2pdf PRO + crypt AIX executable .tar.gz
The txt2pdf PRO + crypt HP-UX executable .tar.gz
         get txt2pdf

The registration fee is

  • $1500 (US) for 1 CPU computer
  • $1700 (US) for 2 or 3 CPU computers (or dual-core)
  • $1950 (US) for 4 to 7 CPU computers
  • $2250 (US) for 8 to 15 CPU computers
  • $2600 (US) for 16 or more CPU computers
for every server installation.

Description | Payment Options
Register NOW txt2pdf PRO + crypt via a SECURE SERVER at www.RegSoft.COM | SECURE MasterCard, VISA,American Express, Check, Fax, Voice Register txt2pdf PRO + crypt now!

UPGRADE POLICY
You can upgrade txt2pdf PRO + crypt 5.x, 6.x, 7.x to the new version with the discount of the amount you previously paid + a fix fee for every license:

  • $200 for 7.x
  • $300 for 6.x
  • $400 for 5.x
Do you have a dubt, contact us via email at sanface@sanface.com for more information on how to upgrade your version.

VOLUME DISCOUNT

4-10 | $1400 each (no CPU server difference)
11-100 | $1250 each (no CPU server difference)

NO LIMIT LICENCE
You've one or more products with a lot of installations and you want to put txt2pdf inside your every tool. This is the licence you're looking for. Its costs: $65000 + 20 % every year. Obviously you'll receive every update freely.

Installing txt2pdf PRO + crypt

You can use the new features like line options ( -no-copy -no-print -no-edit -no-notes) So you can use the same installation notes you can find at txt2pdf and at txt2pdf PRO

Syntax

txt2pdf [-options] files

these are the new options:
    -no-copy                     do not allow cut & paste
    -no-print                    do not allow printing of file
    -no-edit                     do not allow to edit the file
    -no-notes                    do not allow to edit/add notes
    -pass password               to set the user password
    -ownerpass password          to set the owner password
    -permissions="-nn"           see Adobe reference manual; This
                                 option can be used to set permission
                 from its numerical representation.
    -R=2                         use 40 bit encryption
    -R=3                         use 128 bit encryption (for Acrobat 5)
This is a simple example to create from yourtext.txt a PDF encrypt that the final user can't cut & paste and print (128 bit)
txt2pdf -compress -no-copy -no-print -R=3 yourtext.txt
Our txt2pdf PRO + crypt executables are generated by perl2exe tool PERL2EXE logo

txt2pdf PRO + crypt is a trademark of SANFACE Software© 2006.


books

Books and Software

A list of PDF softwares and books we suggest you:

In Association with amazon.com

Search Now:
In Association with Amazon.com


txt2pdf on Acorn-Risc

txt2pdf on Acorn-Risc by
Joern-Erik LEO Burkert

I have got yesterday Perl 5.005 for Acorn-machines and.... txt2pdf runs!
No problem - no change in the script is necessary. I recommend following things: Users (with RiscOS 3.5) should use X-files (or a similar filesystem) - if someone have RiscoS 4.0 there is no need for X-Files.

Create a new X-Files-drawer and unpack the perl-script and the configuration file to this new drawer.
Then they have to change the filetype of the script (txt2pdf) to PERL (the !Perl-appliaction must be seen by the filer).
Now they can use in taskwindow/shell the script.

For viewing the new pdf-document - you have to set the filetype to PDF and view the pdf-file with !PDF.

Tested with a RiscPC/StrongARM-200 and RiscOS 3.5 (64MByte RAM).

I hope this helps!

In Association with Amazon.com

SANFACE Software logo

txt2pdf is a trademark of SANFACE Software© 2004.


txt2pdf on Amiga

txt2pdf on Amiga by
Joern-Erik LEO Burkert

Basicly there are no changes necessary, if you have a patch for the execute-command on Amiga (comes with the Apache-webserver for Amiga).
If the users haven't this patch: They have only to change the 1st line in the script from #!/usr/bin/perl to #!/bin/perl
Additional you have to set the script-flag with the protect-command - then it is possible to execute the script form the shell.

Thats all ;-)

Regards LEO

In Association with Amazon.com

SANFACE Software logo

txt2pdf is a trademark of SANFACE Software© 2004.


Cyrillic and txt2pdf

Cyrillic and txt2pdf by
Ilya Naumov

txt2pdf successfully converts cyrillic koi8-r encoded texts.

I've saved http://camel.gu.ru/links/links.phtml as text and converted it into pdf with txt2pdf (links.pdf). Both ghostview and adobe acrobat reader read the resulting file successfully.

In Unix, you just need to install additional russian fonts in koi8-r encoding and slightly tune X configuration. As long as I remember, the only thing you should do is to take one of russian font sets (like ftp://camel.gu.ru/pub/cyrillic_k.tgz), unpack it to some place and add a string like

FontPath        [path]
to XF86Config, where [path] is a path to unpacked fonts. for example, my XF86Config consists of only 2 FontPath strings:
FontPath        /usr/X11R6/lib/X11/fonts/cyr
FontPath        /usr/X11R6/lib/X11/fonts/misc   # created by XFree86
                                                # distribution
Russian characters in koi8-r encoding cannot be read under Windows with its cp1251 encoding (and vice versa). In Windows, you should first change your regional settings to to Russia (fonts in cp1251 encoding will be installed automatically)
In Windows NT: Control Panel -> Regional Settings -> Russian
I also recommend to check the checkbox "Set as default locale". I have no Win95/98 machine near my workplace, but the way to change locale for them is similar to WinNT.
Then convert your text file from koi8-r to cp1251
This problem could be easily solved with various converters, such as fromwin/towin programs from d1489 package (ftp://ftp.kiarchive.ru/pub/unix/convert/char/d1489-1.4.tgz).
Probably it's possible to make this conversion also after the PDF creation.

It may be interesting to take a look at the existing converter written in perl: http://www.neystadt.org/cyrillic/

In Association with Amazon.com

SANFACE Software logo

txt2pdf is a trademark of SANFACE Software© 2004.


txt2txt: text to text filter

SANFACE Software logo description

SANFACE Software logo is a yellow design on a white background.
The logo is: 5 squares one inside the other and the SANFACE Software name written on a circle outside the bigger square.
SANFACE on the top half circle and Software on the bottom half circle.


MPEiX: convert spoolfiles to PDF?

MPEiX: convert spoolfiles to PDF? by
Mark Bixby

Spoolfiles are a special MPE filetype used to send output to printers. The format of their records is documented in the "Spool File Block Format (SBF)" chapter of: http://docs.hp.com/mpeix/pdf/32650-90867.pdf

The format is EXTREMELY unfriendly to process manually. I once wrote a program to transfer spoolfiles to an IBM printing subsystem, and it was really, really painful to process P1, P2, and the CCTL byte correctly in order to produce printed output the same way it would appear if printed on an MPE printer.

MPE uses special carriage control bytes (CCTL) that determine line spacing, page ejects, etc. It's not simply a matter of inserting multiple NL characters for double or triple spacing or inserting a single FF character for a page eject.

When MPE users ask "Can I convert my spoolfiles to PDF?" they mean they want to preserve the CCTL information. I.e. if the spoolfile would print double spaced, they want the PDF to appear double spaced.

Spoolfiles are a native MPE file format, and Perl is a POSIX program. When POSIX was added to MPE, a new POSIX bytestream file format was created, and behaves just like it would on a Unix system. However, you can still access native MPE files through POSIX I/O functions, and when you do this, the MPE files are emulated to look like POSIX bytestream files. But since MPE files may sometimes have attributes that don't exist on POSIX, you lose the abilities to even see these attributes if you're using the POSIX API.

Unfortunately for spoolfiles, you aren't able to see the P1, P2, and CCTL values while using the POSIX API that Perl uses for its I/O, and since P1, P2, and CCTL are required to determine line spacing and page ejects, you wouldn't be able to create proper PDF output.

So I'm afraid that it's not possible today to use a 100% Perl program to convert spoolfiles into PDF in a way that preserves line spacing.

Someday I want to create an MPE-specific Perl extension XS that would allow access to the native MPE file API. With this it would be possible to read spoolfiles correctly. But unfortunately I can't even guess at when I might be able to start a project like this.

Mark Bixby
Perl/iX for HP e3000 MPE (version 5.5) http://www.bixby.org/mark/perlix.html perl hp freeware for mpe/ix (version 6.0) http://jazz.external.hp.com/src/hp_freeware/perl/

A user nofied us:
With perl v5.6.1 built for PA-RISC1.1 only MANAGER.SYS can run PERL.
The problem was the install of PERL did not configure the permissions correctly for all of the libraries the program uses. To display the libraries you type this in at the MPE prompt:
:XEQ VERSION.PUB.SYS PERL.PUB.PERL
Then, check the libraries from this listing in the POSIX shell. Two of mine only had "rwx" for MANAGER.SYS. After I did a 'chmod' on them to allow world access, it worked. The two I had to modify were /usr/lib/libcurses.sl and /usr/lib/libstr.sl.

In Association with Amazon.com

SANFACE Software logo

txt2pdf is a trademark of SANFACE Software© 2005.


txt2pdf on Lotu Notes

txt2pdf on Lotus Notes

I can think of a couple of ways you can incorporate txt2pdf into notes.
The first way is by giving txt2pdf users the ability to attach the converted pdf files to a internal document within Notes automatically. I am doing that from perl using OLE.
The other way is a bit more involved. Lotus Notes uses a very powerful language called LotusScript. LotusScript programmers have the ability to import custom classes (ie. class to convert text to pdf) using a C API or LSX package.
LotusScript already has the ability to work with the file system and having a text2pdf LotusScript API would prevent the need to shelling out to the operating system. Potentially this could be used with any Lotus product that used LotusScript (ie. Lotus 123, Lotus Word Pro, Lotus Approach, etc.). From a Lotus Notes standpoint. LotusScript would be able to convert text to pdf on a schedule. It could run LotusScript like a CGI program. It could be initiated from a GUI type environment on the Notes client. It could be initiated from the web.

Info on LSX
Info on C API
Info on OLE for notes in perl::Win32 (look for the 'How do I use Lotus Notes link' perlwin32faq12.html)

In Association with Amazon.com

SANFACE Software logo

txt2pdf is a trademark of SANFACE Software© 2004.


txt2pdf on OpenVMS

TXT2PDF.COM is a short DCL procedure to interface with the script (replacement for #!/usr/bin/perl in Unix) :

Actually, the safest TXT2PDF.COM would be like this

$ INSTALL_DIR   = F$PARSE(F$ENVIRONMENT("PROCEDURE"),,,,"NO_CONCEAL")-"]["
$ INSTALL_DIR   =F$EXTRACT(0,F$LOCATE("]",INSTALL_DIR)+1,INSTALL_DIR)-".000000"
$ perl 'INSTALL_DIR'TXT2PDF.; 'p1' 'p2' 'p3' 'p4' 'p5' 'p6' 'p7' 'p8' !
Safest because : usage of NO_CONCEAL and -"][" prevents from screw up in case of multiply chained VMS logicals definitions. Usage of -".000000" is added to support installation in perl_root:[000000] a very common directory for perl script installation. The ultimate would be to use the wrapper I have previously sent (but that would require a make file which appends to an OS-dependant wrapper the perl script.)

The POD documentation is really the best for distributing a perl-based help.

        pod2man txt2pdf.pod >txt2pdf.man
        pod2html txt2pdf.pod >txt2pdf.html
        pod2hlp txt2pdf.pod
The last command can be be used only if the POD2HLP.PM from Dan Susgalski is installed (on the Perl module archive). pod2man usually comes with perl distribution, perl2html has been added in recent versions of perl.

User may include the generated TXT2PDF.HLP in the Help library (either LIBRARY/REPLACE SYS$HELP:HELPLIB.HLB TXT2PDF.HLP or any suitable library for "freeware").

Multiuser Features

A system manager can install txt2pdf and provide a default .cfg file for his users/organization

define/system TXT2PDF wherever:default.cfg VMS in SYLOGIN.COM for example

A user can still overwrite the value using another setenv or define command in his own .cshrc/login.com if he wants to have a default file of his own. A user can still have a working directory with a txt2pdf.cfg file and have it loaded if exists. This allows him (without command line option) to setup fully functional working directories. He can also (as he wishes) use the -configure option to overwrite any defaults.

OpenVMS perl documentation:
The PERL Programing Language
Compress::Zlib

In Association with Amazon.com

SANFACE Software logo

txt2pdf is a trademark of SANFACE Software© 2004.


Text to PDF generation using a standard SCO lp command

Generating and emailing PDF files using SCO Openserver 5 via the LP spooler using txt2pdf by
Gavin Jackson

SCO Openserver is a versatile commercial operating system, It has been the workhorse of many businesses for years now. The operating system supports both local and remote printer types (Along with HP network print servers). By default, the operating system has a version of sendmail installed to handle email from the server to other email destinations. Perl 5.005 is available from www.sco.com/skunkware as a "custom" installable package to enhance the operating system. By using the inbuilt features in the operating system and the readily available perl, we are able to create e-mailable reports from the system via the printer spooler in real time using the local printer command suite

This allows us to send and format reports via email to virtually any emailable destination.

The following informatiion outlines the methods and installation method of the tools. I trust you will find it as useful as we do.

How SCO printing works

SCO Openserver uses files located in the /usr/spool/lp/model directory as base templates for it's printers.
When a printer is created it takes a copy of the base script and copies it to the /usr/spool/lp/admins/lp/interfaces directory as the printer name that you specify.
For example, Creating a printer called "local" is achieved by the printer creation program copying the /usr/spool/lp/model/standard script to the /usr/spool/lp/admins/lp/interfaces/local file.
After the spooler has created the spooler queue, It is possible to use the lp command such as
lp -d local /etc/hosts
to print out the file using the print spooler as normal.

We use a modified version of the base "standard" script to create the the PDF email files.

Requirements

- SCO Openserver 5.0.4 or greater (5.0.5 and 5.0.6 have been successfully tested)

- Perl 5.004 or greater (available from www.sco.com/skunkware as a custom installable package)

- Sanface's Brilliant TXT2PDF script

- MPACK 1.5 (To encapsulate the PDF as an attachment)

- Your time and Skills

Installation

Copy the pdfmail script in this directory to the /usr/local/lp/model directory and set it's permissions to the same as the other printers in the directory.
Download the executable copy of mpack from ftp://ftp2.caldera.com/pub/skunkware/osr5/vols/mpack-1.5-VOLS.tar and install it into your /usr/bin directory of your server. Source txt2pdf and install it.
On my system, I use the /txt2pdf directory to locate the SANFACE software.
Using the standard scoadmin printer manager tool from the command line, Create a printer called pdfmail using the standard model of pdfmail as it's model type, Under device modify to /dev/null as the output source. (This is a standard SCO method of printer installation for a local printer)

Testing

At the command prompt, Type in
lp -d pdfmail -t <Your email address> /etc/hosts
and your SCO server should generate an email with your /etc/hosts file attached as a pdf file and email to your email address.
The advantage of using this method of printing is that you are using the local printer spooler to manage the pdf generation and this extra feature can be added to most existing legacy applications.
We use the -t option to pass the email address of the mail recipient to the spooler as a standard variable. Normally this option is used to add a title to the banner page which can be sent on a page preceding a normal printout, as this is rarely used, We use this option as the email recipient address.

Document Author

Gavin Jackson
Technical Manager
www.insurance.com.au
email: gavin@insurance.com.au

In Association with Amazon.com

SANFACE Software logo

txt2pdf is a trademark of SANFACE Software© 2004.